Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Errore x11-libs/cairo-1.16.0-r3
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 572
Location: Italia

PostPosted: Sun Mar 08, 2020 11:53 am    Post subject: [RISOLTO] Errore x11-libs/cairo-1.16.0-r3 Reply with quote

Ciao a tutti,
aggiornando il sistema ottengo un errore su x11-libs/cairo-1.16.0-r3.

Questo è l'errore:

Quote:
make[5]: Leaving directory '/var/tmp/portage/x11-libs/cairo-1.16.0-r3/work/cairo-1.16.0-abi_x86_64.amd64/boilerplate'
/bin/sh ../../libtool --tag=CC --mode=link x86_64-pc-linux-gnu-gcc -D_REENTRANT -I/usr/include/pixman-1 -I/usr/include/uuid -I/usr/include/freetype2 -I/usr/include/freetype2 -I/usr/include/libpng16 -Wall -Wextra -Wmissing-declarations -Werror-implicit-function-declaration -Wpointer-arith -Wwrite-strings -Wsign-compare -Wpacked -Wswitch-enum -Wmissing-format-attribute -Wvolatile-register-var -Wstrict-aliasing=2 -Winit-self -Wunsafe-loop-optimizations -Wno-missing-field-initializers -Wno-unused-parameter -Wno-attributes -Wno-long-long -Winline -fno-strict-aliasing -fno-common -Wp,-D_FORTIFY_SOURCE=2 -Wno-unused-but-set-variable -D_REENTRANT -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -march=native -O2 -pipe -Wl,-O1 -Wl,--as-needed -o cairo-sphinx cairo_sphinx-sphinx.o -lpthread ../../util/cairo-script/libcairo-script-interpreter.la ../../boilerplate/libcairoboilerplate.la ../../src/libcairo.la -lglib-2.0 -lrt -lrt -lm
libtool: link: x86_64-pc-linux-gnu-gcc -D_REENTRANT -I/usr/include/pixman-1 -I/usr/include/uuid -I/usr/include/freetype2 -I/usr/include/freetype2 -I/usr/include/libpng16 -Wall -Wextra -Wmissing-declarations -Werror-implicit-function-declaration -Wpointer-arith -Wwrite-strings -Wsign-compare -Wpacked -Wswitch-enum -Wmissing-format-attribute -Wvolatile-register-var -Wstrict-aliasing=2 -Winit-self -Wunsafe-loop-optimizations -Wno-missing-field-initializers -Wno-unused-parameter -Wno-attributes -Wno-long-long -Winline -fno-strict-aliasing -fno-common -Wp,-D_FORTIFY_SOURCE=2 -Wno-unused-but-set-variable -D_REENTRANT -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -march=native -O2 -pipe -Wl,-O1 -o .libs/cairo-sphinx cairo_sphinx-sphinx.o -Wl,--as-needed ../../util/cairo-script/.libs/libcairo-script-interpreter.so -llzo2 ../../boilerplate/.libs/libcairoboilerplate.a /var/tmp/portage/x11-libs/cairo-1.16.0-r3/work/cairo-1.16.0-abi_x86_64.amd64/src/.libs/libcairo.so ../../src/.libs/libcairo.so -lpthread -lpixman-1 -lfontconfig -lfreetype -lEGL -ldl -lpng16 -lxcb-shm -lxcb -lxcb-render -lXrender -lX11 -lXext -lz -lGL -lglib-2.0 -lrt -lm
/usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/../../../../lib64/libGL.so: undefined reference to `_glapi_tls_Current'
collect2: error: ld returned 1 exit status
make[4]: *** [Makefile:604: cairo-sphinx] Error 1
make[4]: Leaving directory '/var/tmp/portage/x11-libs/cairo-1.16.0-r3/work/cairo-1.16.0-abi_x86_64.amd64/util/cairo-sphinx'
make[3]: *** [Makefile:1002: all-recursive] Error 1
make[3]: Leaving directory '/var/tmp/portage/x11-libs/cairo-1.16.0-r3/work/cairo-1.16.0-abi_x86_64.amd64/util'
make[2]: *** [Makefile:779: all] Error 2
make[2]: Leaving directory '/var/tmp/portage/x11-libs/cairo-1.16.0-r3/work/cairo-1.16.0-abi_x86_64.amd64/util'
make[1]: *** [Makefile:908: all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/x11-libs/cairo-1.16.0-r3/work/cairo-1.16.0-abi_x86_64.amd64'
make: *** [Makefile:759: all] Error 2
* ERROR: x11-libs/cairo-1.16.0-r3::gentoo failed (compile phase):
* emake failed
*
* If you need support, post the output of `emerge --info '=x11-libs/cairo-1.16.0-r3::gentoo'`,
* the complete build log and the output of `emerge -pqv '=x11-libs/cairo-1.16.0-r3::gentoo'`.
* The complete build log is located at '/var/tmp/portage/x11-libs/cairo-1.16.0-r3/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/x11-libs/cairo-1.16.0-r3/temp/environment'.
* Working directory: '/var/tmp/portage/x11-libs/cairo-1.16.0-r3/work/cairo-1.16.0-abi_x86_64.amd64'
* S: '/var/tmp/portage/x11-libs/cairo-1.16.0-r3/work/cairo-1.16.0'


Questo è il mio make.conf:

http://dpaste.com/1TSD06T


Grazie


Last edited by Maxxx on Sun Mar 08, 2020 3:34 pm; edited 1 time in total
Back to top
View user's profile Send private message
fturco
Veteran
Veteran


Joined: 08 Dec 2010
Posts: 1166
Location: Italy

PostPosted: Sun Mar 08, 2020 12:15 pm    Post subject: Reply with quote

Puoi postare per favore l'output di emerge --info x11-libs/cairo e quello di ldd /usr/lib64/libGL.so?
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 572
Location: Italia

PostPosted: Sun Mar 08, 2020 12:23 pm    Post subject: Reply with quote

Grazie per la risposta... non appena rientro a casa lo faccio.
Back to top
View user's profile Send private message
fturco
Veteran
Veteran


Joined: 08 Dec 2010
Posts: 1166
Location: Italy

PostPosted: Sun Mar 08, 2020 12:40 pm    Post subject: Reply with quote

Ho trovato anche questo bug che potrebbe esserti utile.
Back to top
View user's profile Send private message
Maxxx
Guru
Guru


Joined: 12 Jan 2016
Posts: 572
Location: Italia

PostPosted: Sun Mar 08, 2020 3:34 pm    Post subject: Reply with quote

Grazie mille... risolto come hanno detto sul bug:

1) emerge --nodeps -1 nvidia-drivers
2) emerge -1 mesa xorg-server

Ora sta andando avanti con l'emerge world.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum