Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(RISOLTO) xfce schermata nera
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
darkfor.del
n00b
n00b


Joined: 13 Feb 2020
Posts: 41

PostPosted: Fri Feb 28, 2020 2:54 pm    Post subject: (RISOLTO) xfce schermata nera Reply with quote

Salve, scusate che faccio un post nuovo ma penso che sia il caso essendo che e un problema diverso del problema principale dell'altro post. Io avevo scritto sul precedente post alla fine che sarei ritornato su Arch perché momentaneamente mi sono stufato ma questa mattina ho cambiato idea e mi e ritornata la voglia... Quindi mi sono fatto una installazione pulita ma purtroppo Gentoo mi ha fatto lo stesso scherzo di ieri, cioè con il primo reboot con l'ambiente grafico e login installati mi ha fatto funzionare tranquillamente lightdm e mi ha fatto accedere a xfce ma dopo aver fatto la modifica al file fstab da percorso partizioni a UUID, basta il primo riavvio che mi attiva lightdm ma dopo la password e avvio si vede solo una schermata nera, pure riportando il file fstab come era prima con i percorsi della partizioni non fa più accedere all'ambiante grafico. Rispetto a ieri ho fatto una ulteriore prova per capire meglio se fosse lightdm o xfce il problemi, ho installato pure Mate (infatti sto scrivendo questo post con un Gentoo Mate attivo) e funziona tranquillamente con il file fstab modificato in UUID. Io non riesco a capire il motivo essendo che prima che modifico il file fstab si riesce ad accedere senza problemi ma quando lo faccio... Infondo Mate non mi dispiace ma preferisco XFCE. Io prima di rinunciare a XFCE (cancellarlo) ho preferito fare questo post, sapete darmi una spiegazione o un consiglio? Grazie

Last edited by darkfor.del on Mon Mar 02, 2020 5:50 pm; edited 3 times in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24053
Location: here

PostPosted: Fri Feb 28, 2020 3:02 pm    Post subject: Reply with quote

Puoi postare qualche log di lightdm di quando cerchi di avviare xfce?
Se cerchi di fare partire xfce con startx funziona?
Puoi postare il tuo emerge --info?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
darkfor.del
n00b
n00b


Joined: 13 Feb 2020
Posts: 41

PostPosted: Fri Feb 28, 2020 5:14 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Puoi postare qualche log di lightdm di quando cerchi di avviare xfce?
Se cerchi di fare partire xfce con startx funziona?
Puoi postare il tuo emerge --info?


Non funziona

Foto startxfce4

https://ibb.co/y8jZCSj

Foto startx

https://ibb.co/fM4ZM7s

emerge --info

http://dpaste.com/1W3C077
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24053
Location: here

PostPosted: Fri Feb 28, 2020 5:53 pm    Post subject: Reply with quote

Per prima cosa non fare startx da root ma crea un utente non privilegiato e fallo da li.
Il comando startxfce4 ti dice che il server X e' gia' attivato probabilmente perche' hai lightdm ancora attivo, disattovalo con /etc/init.d/xdm stop.
Il comando startx invece ti dice che manca twm, xclock e xterm perche' se non crei il file .xinitrc nella tua home con scritto dentro exec startxfce4 di default vuole avviarti twm.
Quindi ricapitolando dovresti stoppare ligthdm con il comando /etc/init.d/xdm stop, creare il file .xinitrc con il contenuto exec startxfce4 nella home di un utente non privilegiato e infine eseguire il comando startx (per vedere se cosi' parte).
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
darkfor.del
n00b
n00b


Joined: 13 Feb 2020
Posts: 41

PostPosted: Sat Feb 29, 2020 8:15 am    Post subject: Reply with quote

fedeliallalinea wrote:
Per prima cosa non fare startx da root ma crea un utente non privilegiato e fallo da li.
Il comando startxfce4 ti dice che il server X e' gia' attivato probabilmente perche' hai lightdm ancora attivo, disattovalo con /etc/init.d/xdm stop.
Il comando startx invece ti dice che manca twm, xclock e xterm perche' se non crei il file .xinitrc nella tua home con scritto dentro exec startxfce4 di default vuole avviarti twm.
Quindi ricapitolando dovresti stoppare ligthdm con il comando /etc/init.d/xdm stop, creare il file .xinitrc con il contenuto exec startxfce4 nella home di un utente non privilegiato e infine eseguire il comando startx (per vedere se cosi' parte).


scusa hai ragione, sono io che mi sono dimenticato di uscire dal root e quella del login non lo sapevo

con startx mi da queste scritte

https://ibb.co/P59T6Qd

mentre con startxfce4 mi parte xfce ma mi fa questi effetti sul menu e qualsiasi scritte, è normale con startxfce4?

https://ibb.co/vd9ZtSq

Io ci ho riprovato dopo aver attivato xdm di far partire xfce con il login ma ancora schermata nera
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24053
Location: here

PostPosted: Sat Feb 29, 2020 6:36 pm    Post subject: Reply with quote

darkfor.del wrote:
con startx mi da queste scritte

https://ibb.co/P59T6Qd

Questo perche' non hai creato il file .xinitrc come detto in precedenza.

darkfor.del wrote:
mentre con startxfce4 mi parte xfce ma mi fa questi effetti sul menu e qualsiasi scritte, è normale con startxfce4?

https://ibb.co/vd9ZtSq

No non e' normale, hai seguito la relativa guida per la tua scheda grafica?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
darkfor.del
n00b
n00b


Joined: 13 Feb 2020
Posts: 41

PostPosted: Sat Feb 29, 2020 8:23 pm    Post subject: Reply with quote

fedeliallalinea wrote:
darkfor.del wrote:
con startx mi da queste scritte

https://ibb.co/P59T6Qd

Questo perche' non hai creato il file .xinitrc come detto in precedenza.

darkfor.del wrote:
mentre con startxfce4 mi parte xfce ma mi fa questi effetti sul menu e qualsiasi scritte, è normale con startxfce4?

https://ibb.co/vd9ZtSq

No non e' normale, hai seguito la relativa guida per la tua scheda grafica?


Ma il fatto del file .xinitrc non lo mai fatto perché mi ha sempre gestito tutto il login, cioè non l'ho mai creato manualmente. Per la scheda video, la cosa non sembra normale perché, prima che modifico il file fstab come scritto in precedenza mi parte xfce ma non ho neppure problemi grafici e pure Mate che mi funziona tranquillamente non ha problemi grafici, per il fatto del kernel, installo un kernel binario che tu mi hai consigliato per il fatto che con la mia scheda video dopo il primo rebbot dopo l'installazione della base di sistema non parte ma pensandoci mi sembra anche normale per il fatto che dopo il kernel 5 sono compatibili la serie della mia scheda video (almeno mi sembrava averlo letto su qualche sito e mi è ritornato la memoria adesso dell'artiolo)
Back to top
View user's profile Send private message
darkfor.del
n00b
n00b


Joined: 13 Feb 2020
Posts: 41

PostPosted: Sat Feb 29, 2020 8:57 pm    Post subject: Reply with quote

Comunque, va bene, dire la verità adesso accetto Mate e basta. Tanto per il motivo che volevo xfce era per il fatto che il mio ambiente grafico preferito invece è KDE (infatti mi ero installato Gentoo con KDE prima di tentare una installazione pulita per xfce) ma Gentoo e la distribuzione che mi affascina di più ma non lo trovo un sistema adatto per ambianti grafici tanto pesanti e con probabiliti aggiornamenti frequenti e poi per quanto mi piace veramente tanto tutte la funzioni e l'estetica di KDE comunque in ogni modo la maggior parte non lo uso quasi mai, qualche prova ogni tanto e per noia ma non mi servono quindi, perché pesantire il proprio computer di funzioni che alla fine non ti servono? Allora, anche se il mio PC non è datato e l'ho assemblato circa 5 mesi fa, comunque con Gentoo preferisco un ambiante leggero e che mi dia un senso di stabilità maggiore. In pratica, molto probabilmente sarà un bug o qualcos'altro perché come ripeto Mate funziona, XFCE no... quindi, pure Mate infondo non è proprio male e sono disposto usare Mate, non sono un nostalgico di gnome 2 essendo che l'epoca era un adolescente appassionato d'informatica che ha solo provato alcune distribuzione come Ubuntu solo per pochi minuti ma non lo trovo male anche nella sua estetica e quindi, domani farò una installazione pulita e installerò direttamente Mate, anche perché per farmi un sistema completo con tutti i software installati ci vorranno veramente molte ore e non vedo l'ora di iniziare, per finire prima... e se ci saranno problemi come se Mate mi farà lo scherzo di xfce lo scriverò su questo post e ti ringrazio fedeliallalinea mi hai aiutato più di una volta! ;)
Back to top
View user's profile Send private message
darkfor.del
n00b
n00b


Joined: 13 Feb 2020
Posts: 41

PostPosted: Mon Mar 02, 2020 5:40 pm    Post subject: Reply with quote

Beh! infondo risolto non è vero ma come promesso sul commento precedente ho fatto una installazione pulita e ho un sistema completo con tutti i software che mi servono già installati con Mate e funziona da dio! Io l'unica ipotesi che posso farmi è che avranno lasciato un bug sulla nuova versione di xfce (4.14) perché Mate l'ho installato come ho fatto con xfce e pure su Mate ho modificato i parametri del file fstab ma Mate funziona
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum