Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gentoo-kernel - erste Erfahrungen
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Diskussionsforum
View previous topic :: View next topic  
Author Message
ManfredB
Guru
Guru


Joined: 27 Dec 2007
Posts: 593

PostPosted: Thu Jan 23, 2020 8:32 am    Post subject: gentoo-kernel - erste Erfahrungen Reply with quote

Hallo zusammen,

in diesem Forum sind wir auf eine neue Entwicklung bei gentoo aufmerksam gemacht worden:

gentoo-kernel - anders als gentoo-sources bereits ein komplett fertiger Kernel.

Mein erster Versuch auf meinem PC mit NVIDIA-Grafikkarte ist gescheitert.

Aber ich gebe in solchen Situationen nie auf.

Auf meinem Notebook Acer Aspire mit Intel-Grafikkarte war es überhaupt kein Problem.

Nun weiß ich ja schon lange, daß neben den nvidia-drivers auch noch der nouveau-Treiber existiert.

Gestern habe ich also eine Neuinstallation gestartet und dabei
gentoo-kernel-bin-5.4.13-gentoo-x86_64 installiert.

In der /etc/portage/make.conf steht nun statt nvidia nouveau.

Bei der Installation des Kernels wird ja ausdrücklich darauf hingewiesen, daß das noch ein Testprogramm ist,
der Vorschlag, sicherheitshalber gentoo-sources daneben zu installieren, hat mich schon etwas unsicher gemacht,
was den gentoo-kernel angeht.

Dennoch habe ich die komplette Neuinstallation gewagt.

Daß ich nun gentoo mit diesem neuen Kernel nutzen kann, ist ein großer Fortschritt,
da muß ich demjenigen, der diese Information ins Forum gestellt hat, ausdrücklich zustimmen
und auch noch einmal hier danke für diese Information sagen.

Ich wünsche allen, die diesen neuen Kernel auch testen, viel Erfolg und genauso viel Freude,
wie ich sie erlebt habe, wenn es wirklich klappt.

Gruß
Manfred
Back to top
View user's profile Send private message
ManfredB
Guru
Guru


Joined: 27 Dec 2007
Posts: 593

PostPosted: Fri Jan 24, 2020 4:02 pm    Post subject: Reply with quote

Nachtrag:

Die gentoo-kernel sind nur für die Test-Version: ACCEPT_KEYWORDS="~amd64".

Ich wollte heute einmal wieder stable installieren und den Versuch mit gentoo-kernel machen.

Doch wie beschrieben, ist das nicht möglich. Eigentlich verständlich, weil das ja Testversionen sind.

Auch wenn 4.19.86 und 4.19.97 und 5.4.12 und 5.4.13 vorhanden sind, alle sind masked.

Das nur noch zur Information.

Gruß
Manfred
Back to top
View user's profile Send private message
ManfredB
Guru
Guru


Joined: 27 Dec 2007
Posts: 593

PostPosted: Fri Jan 24, 2020 8:20 pm    Post subject: Reply with quote

Noch ein Nachtrag.

Da ich nie aufgebe, sondern weiter versuche, das zu Ende zu bringen, was ich angefangen habe,
bin ich bei der Neuinstallation von gentoo-stable mit einem kleinen Trick weitergekommen.

Nachdem ich in die chroot-Umgebung gekommen bin und emerge --sync --quiet beendet war,
habe ich nicht zuerst das Riesenupdate laufen lassen, sondern zuerst /etc/portage/make.conf
mit ACCEPT_KEYWORDS="~amd64" ergänzt, dann
emerge --ask sys-kernel/gentoo-kernel ausgeführt.

5.4.13 wurde problemlos installiert. danach habe ich die Zeile mit ~amd64 wieder entfernt.

Dann bin ich genau nach dem WIKI vorgegangen, habe alle Schritte ausgeführt, ausgenommen
genkernel, denn den brauche ich bei einem fertigen Kernel nicht mehr.

Alles andere war soweit fertig, dann habe ich begonnen, die für mich wichtigen Programme zu installieren:
app-misc/mc eix gentoolkit
kde-plasma/plasma-meta
kde-plasma/plasma-nm
kdeadmin-meta
kdegraphics-meta
kdemultimedia-meta
kdeutils-meta
kdialog kmahjongg konsole krusader kwrite
gparted gutenprint xsane
adobe-flash alsa-tools firefox-bin phonon-gstreamer thunderbird-bin
libreoffice libreoffice-l10n

Die meisten der aufgeführten Pakete waren binpkgs,
allerdings am Ende
emerge -avuDN world,
um nichts zu übersehen.

rc-update add dbus boot
rc-update add consolekit default
rc-update add cupsd default
rc-update add alsasound default
rc-update add NetworkManager default
/etc/conf.d/xdm geändert von xdm in sddm
rc-update add xdm default
useradd -m -g users -s /bin/bash ~

Und dann habe ich die chroot-Umgebung verlassen,
das System neu gestartet und bin direkt auf dem Login-Screen gelandet.

Nach vollständiger Einrichtung des plasma-Desktops habe ich dann diesen Artikel
geschrieben.

Und ich freue mich, daß der Boot-Vorgang mit dem gentoo-kernel wesentlich schneller geht
als mit dem gentoo-kernel-bin.
Zwar dauert die Installation des gentoo-kernels doch eine ganze Weile,
aber das war mir in diesem Fall egal.

Fazit: Einmal ohne Konfiguration des Kernels auszukommen, ist schon eine Freude - jedenfalls für mich.

Ich wünsche allen, die mit dem gentoo-kernel einen Versuch starten, denselben Erfolg, den ich heute erlebt habe.

Gruß
Manfred
Back to top
View user's profile Send private message
ManfredB
Guru
Guru


Joined: 27 Dec 2007
Posts: 593

PostPosted: Sat Jan 25, 2020 8:37 am    Post subject: Reply with quote

Inzwischen sind auch gentoo-kernel und gentoo-kernel-bin 5.4.14 aufgetaucht.

Beide Kernel habe ich auf meinem PC in zwei Test-Installationen untergebracht.

Alles funktioniert einwandfrei.

Gruß
Manfred
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4576

PostPosted: Sat Jan 25, 2020 8:51 am    Post subject: Reply with quote

Du kennst schon /etc/portage/package.accept_keywords oder?
Dadurch kannst du für einzelne Pakete die "unstable" (e.g. ~amd64) versionen freischalten.

Dadurch musst du nicht temporär ACCEPT_KEYWORDS in der make.conf anpassen um ein unstable version eines paketes zu installieren
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
ManfredB
Guru
Guru


Joined: 27 Dec 2007
Posts: 593

PostPosted: Sun Jan 26, 2020 5:54 pm    Post subject: Reply with quote

Danke für den Hinweis,

daran habe ich gar nicht mehr gedacht.

Gruß
Manfred
Back to top
View user's profile Send private message
ManfredB
Guru
Guru


Joined: 27 Dec 2007
Posts: 593

PostPosted: Thu Feb 27, 2020 3:17 pm    Post subject: Reply with quote

gentoo-kernel-5.5.6 ist inzwischen vorhanden.

Auch den habe ich heute installiert (im Rahmen einer Neuinstallation mit binpkgs).

Ich bin damit sehr zufrieden, denn die Kernel-Konfiguration entfällt komplett.

Allerdings dauert die Installation ungefähr genauso lange wie wenn ich das Verfahren
mit genkernel und gentoo-sources durchführe.

kernel-bin dagegen geht relativ schnell vonstatten.

Gruß
Manfred
Back to top
View user's profile Send private message
ManfredB
Guru
Guru


Joined: 27 Dec 2007
Posts: 593

PostPosted: Sat Feb 29, 2020 8:51 am    Post subject: Reply with quote

Neue Erahrung:

Bisher hatte ich mit dem nvidia-driver bei gentoo-sources immer wieder Probleme mit verschiedenen Paketen.
Bestimmte Versionen waren mit den nvidia-drivers verknüpft, doch genau diese Versionen sind inzwischen zT aktualisiert worden.
da kam immer eine dicke Liste von Fehlern.

Nun habe ich komplett umgestellt: alle vorhandenen Gentoo-Installationen (stable ausgeschlossen) - unstable und systemd sind gemeint -
sind nun mit gentoo-kernel-bin ausgestattet, und in der make.conf steht nicht mehr nvidia, sondern nouveau.

Und was mir dabei sofort aufgefallen ist: diese Konflikte im Zusammenhang mit den nvidia-drivers sind weg.

Damit bin ich nun sehr zufrieden.

Eines noch: warum ich gentoo-kernel-bin nutze und nicht gentoo-kernel?

Weil gentoo-kernel bei der Installation sehr lange braucht, deutlich länger als gentoo-kernel-bin.

Gruß
Manfred
Back to top
View user's profile Send private message
ManfredB
Guru
Guru


Joined: 27 Dec 2007
Posts: 593

PostPosted: Sun Mar 01, 2020 5:50 pm    Post subject: Reply with quote

Hallo zusammen,

eine sehr gute Erfahrung mit genoo-kernel:

So schnell, wie jetzt gentoo startet, habe ich es bisher noch nicht erlebt.

Installiert ist Gentoo auf einer SSD, da geht sowieso alles schnell.

Aber das Tempo. das ich jetzt erlebe, ist unglaublich.

Zufriedenheit hoch 3 - sagt nicht viel, aber zumindest, daß nicht bereut habe,
auf meinem PC mit gentoo-kernel Tests ausgeführt habe, die Erfolg hatten.

In diesem Sinne: viel Freude mit gentoo-kernel oder gentoo-kernel-bin.

Gruß
Manfred
Back to top
View user's profile Send private message
ManfredB
Guru
Guru


Joined: 27 Dec 2007
Posts: 593

PostPosted: Wed Mar 04, 2020 5:52 am    Post subject: Reply with quote

Gestern habe ich auf meinem PC noch einmal gentoo-kernel installiert.

Das hat genau 44 Minuten in Anspruch genommen. Sehr lange, aber es hat
geklappt.

Ich vermute einmal, daß dieser Kernel so viel an Inhalten hat, um alle Bedürfnisse
zu befriedigen.

Daher die außergewönlich lange Dauer der Installation.

Doch wenn ich zB. die mir in diesem Forum vorgeschlagenen Schritte gehe:
make olddefconfig
make
make install
make modules_install

dann dauert make auch sehr lange.

Aber ich will gleich dazu erwähnen, daß ich bei der Kernel-Konfiguration sehr zurückhaltend bin,
um nicht immer wieder die Erfahrung zu machen, daß das System dann nicht bootet, weil ich entweder etwas vergessen habe oder falsche Einstellungen vorgenommen habe.

Daher ist die gentoo-kernel oder gentoo-kernel-bin - Entwicklung wirklich ein sehr guter Schritt.

Gruß
Manfred
Back to top
View user's profile Send private message
ManfredB
Guru
Guru


Joined: 27 Dec 2007
Posts: 593

PostPosted: Tue Mar 10, 2020 8:05 am    Post subject: Reply with quote

Heute ist mir etwas Merkwürdiges begegnet.

Ausgangspunkt: Neuinstallation von gentoo-unstable mit Kernel-5.5.8, also auch nouveau-Treiber.

Das hat eine Weile gedauert, weil ich es ohne binpkgs durchgeführt habe.

Heute starte ich das neue System und will es einrichten.

Zunächst mit Systemsettings. Als alles fertig war, Neustart.

Was jetzt noch fehlte: ein schönes Hintergrundbild für den plasma-Desktop.

Rechtsklick mit der Maus auf dem Desktop, dann Arbeitsfläche einrichten.
Nun öffnet sich - sehr langsam - ein Fenster mit leeren Flächen, sonst erscheinen dort erste Wallpapers.

Es dauert sehr lange, bis überhaupt mal ein Bild erscheint, dann will ich neue herunterladen,
doch das ist so kompliziert, wie ich es bisher noch nie erlebt habe.

Daher die Frage:
Kann es sein, daß mit dem nouveau-Treiber genau das sehr schwierig ist, denn wenn ich den nvidia-Treiber
in Zusammenhang mit gentoo-sources nutze, habe ich dieses Problem überhaupt nicht - jedenfalls bisher.

Inzwischen habe ich ein Bild installiert, aber wie geschrieben: quälend langsam und kompliziert.

Gruß
Manfred
Back to top
View user's profile Send private message
ManfredB
Guru
Guru


Joined: 27 Dec 2007
Posts: 593

PostPosted: Thu Apr 09, 2020 10:53 am    Post subject: Reply with quote

Heute habe ich einen Test durchgeführt.

gentoo-instable mit gentoo-kernel-5.5.14.

Bis jetzt stand in der /etc/portage/make.conf unter VIDEO_CARDS="nouveau",
das habe ich einfach in nvidia geändert und dann
emerge --ask nvidia-drivers

Das hat geklappt, allerdings mit einer kleinen Einschränkung:
In dem Kernel ist
CONFIG_I2C_NVIDIA_GPU
aktiviert, was nicht sein sollte.

Dennoch ist der Treiber installiert worden.

Allerdings habe ich das System noch nicht neu gestartet, um zu sehen, ob das ohne Probleme läuft.

Es müssen nämlich noch folgende Pakete installiert/reinstalliert werden:

Code:

dev-libs/vala-common-0.48.3::gentoo
x11-base/xorg-drivers-1.20-r1::gentoo
x11-libs/libdrm-2.4.101::gentoo
dev-libs/libfmt-6.2.0-r1::gentoo
dev-lang/vala-0.48.3::gentoo
sys-apps/man-pages-5.05-r2::gentoo
media-libs/mesa-20.0.4::gentoo
media-libs/nv-codec-headers-9.0.18.1::gentoo
sys-apps/portage-2.3.98::gentoo
media-video/ffmpeg-4.2.2::gentoo


Sobald ich rebootet habe, melde ich mich noch einmal.

Gruß
Manfred

P.S. Leider bin ich nicht mehr auf den Desktop gelangt.
Ich werde eine Neuinstallation durchführen und dort testen, ob es doch klappt.
Das dauert aber noch ....
Back to top
View user's profile Send private message
ManfredB
Guru
Guru


Joined: 27 Dec 2007
Posts: 593

PostPosted: Thu Apr 09, 2020 7:34 pm    Post subject: Reply with quote

Hallo zusammen!

Die Neuinstallation ist fertig.

ABER: So langsam und schwerfällig habe ich gentoo noch nicht erlebt.

Fazit: So funktioniert das nicht.

Für diesen Text habe ich deutlich mehr Zeit gebraucht als sonst.

Also muß ich zurück zu gentoo-sources, weil nur damit nvidia klappt.

Gruß
Manfred
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Diskussionsforum All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum