Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
errore compilando gcc
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 717

PostPosted: Mon Dec 23, 2019 6:27 pm    Post subject: errore compilando gcc Reply with quote

salve a tutti .. eiscontro un errore durante la fase di "emerge @preserved-rebuild l'errore e` questo riportato : http://dpaste.com/39011N9

grazie in anticipamente
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24053
Location: here

PostPosted: Mon Dec 23, 2019 7:49 pm    Post subject: Reply with quote

Mi sa che hai lo stesso problema di luna80, usi anche tu ancora il profilo 17.0?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 717

PostPosted: Mon Dec 23, 2019 9:07 pm    Post subject: Reply with quote

Code:
default/linux/amd64/17.0/desktop (stable) *
Si ....
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 717

PostPosted: Mon Dec 23, 2019 9:13 pm    Post subject: Reply with quote

ora vedo di leggere il post di luna90

devo cambiare a 17.1 ?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24053
Location: here

PostPosted: Mon Dec 23, 2019 9:15 pm    Post subject: Reply with quote

Si passando al profilo 17.1, occhio che per fare questo salto devi seguire la relativa news e non basta solo cambiare profilo e fare un update del sistema
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 717

PostPosted: Mon Dec 23, 2019 9:30 pm    Post subject: Reply with quote

si sto seguendo quella guida .. al punto dove dice
Code:

1. Sync and upgrade your system to the newest package versions
   to reduce the risk of issues.



facendo l'upgrate ottengo questo:

These are the packages that would be merged, in order:
Code:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-python/numpy:0

  (dev-python/numpy-1.17.4:0/0::gentoo, ebuild scheduled for merge) USE="lapack -doc -test" ABI_X86="(64)" PYTHON_TARGETS="python3_6 -python3_5 -python3_7 -python3_8" conflicts with
    >=dev-python/numpy-1.6[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/numexpr-2.6.9:0/0::gentoo, installed) USE="-mkl" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -python3_5 -python3_7"
                                                                                                                                                                                                                               
    >=dev-python/numpy-1.9.1[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/bottleneck-1.2.1:0/0::gentoo, installed) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -python3_5 -python3_7"
                                                                                                                                                                                                                                 
    >=dev-python/numpy-1.10[lapack,python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (sci-libs/scipy-1.1.0:0/0::gentoo, installed) USE="-doc -sparse -test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -python3_5 -python3_7"
                                                                                                                                                                                                                                       
    >dev-python/numpy-1.13.1[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/pandas-0.24.2:0/0::gentoo, installed) USE="X (-doc) -full-support -minimal -test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -python3_5 -python3_7"
                                                                                                                                                                                                                                 
    >=dev-python/numpy-1.11[python_targets_python2_7(-),python_targets_python3_6(-),-python_single_target_python2_7(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)] required by (dev-python/dask-1.2.0:0/0::gentoo, installed) USE="-distributed -test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -python3_5 -python3_7"
                                                                                                                                                                                                                               


!!! The following updates are masked by LICENSE changes:
- sys-kernel/linux-firmware-20191215::gentoo (masked by: || ( ) linux-fw-redistributable no-source-code license(s))
A copy of the 'linux-fw-redistributable' license is located at '/usr/portage/licenses/linux-fw-redistributable'.

A copy of the 'no-source-code' license is located at '/usr/portage/licenses/no-source-code'.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Nothing to merge; quitting.


come posso sistemare ?
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 717

PostPosted: Mon Dec 23, 2019 9:45 pm    Post subject: Reply with quote

continua anche se torno a 17.0

Last edited by drudox on Mon Dec 23, 2019 10:25 pm; edited 1 time in total
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 717

PostPosted: Mon Dec 23, 2019 9:48 pm    Post subject: Reply with quote

comunque gli errori continuano :

Code:
unsymlink-lib --analyze
/lib is a real directory! was the migration done already?
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 717

PostPosted: Mon Dec 23, 2019 10:11 pm    Post subject: Reply with quote

come faccio a riniziare la procedura da zero ?
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 717

PostPosted: Tue Dec 24, 2019 7:31 am    Post subject: Reply with quote

ho risolto grazie lo stesso
Back to top
View user's profile Send private message
luna80
Veteran
Veteran


Joined: 01 Feb 2004
Posts: 1167
Location: switzerland

PostPosted: Wed Jan 01, 2020 7:23 am    Post subject: Reply with quote

lo so che ormai è un pò tardi ma in caso che qualcun'altro ha il problema è utile scrivere la soluzione

nel mio caso, non è stato necessario seguire la guida del passaggio dal profilo 17.0 a 17.1, appena ho iniziato a seguirla il messaggio che mi è ritornato da unsymlink-lib --analyze era come il tuo (/lib is a real directory! was the migration done already?)...ho semplicemente cambiato profilo con eselect e ricompilato glibc (prima, altrimenti gcc da errore) e poi gcc
_________________
*** !f j00 c4n r34D tH15 tH3N j00 n33D t0 l0g Off ***
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum