Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Consulta de conflicto de dependencias
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Jack Krauser
Apprentice
Apprentice


Joined: 19 Jan 2011
Posts: 209

PostPosted: Tue Jul 09, 2019 5:40 am    Post subject: Consulta de conflicto de dependencias Reply with quote

Muy buenas a todos...

Al momento de querer actualizar el sistema lo logro hacer con normalidad a pesar de que tengo un conflicto de dependencias que aún no sé cómo resolver. Los conflictos son diferentes en mis dos equipos con Gentoo (uno en mi trabajo y el de casa que es el con el que estoy escribiendo). El mensaje que obtengo es el siguiente:

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

Code:
dev-util/boost-build:0

  (dev-util/boost-build-1.70.0:0/0::gentoo, ebuild scheduled for merge) conflicts with
    =dev-util/boost-build-1.65* required by (dev-libs/boost-1.65.0:0/1.65.0::gentoo, installed)
    ^                     ^^^^^


Me puede echar una mano de cómo resolver eso???

Gracias de antemano
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1421

PostPosted: Tue Jul 09, 2019 2:53 pm    Post subject: Reply with quote

Posiblemente estás haciendo una actualización parcial del sistema en lugar de un emerge @world. En esa actualización se está incluyendo dev-libs/boost pero no se está incluyendo algún paquete que está requiriendo precisamente dev-libs/boost-1.65.0:0/1.65.0::gentoo.

Deberías actualizar con:
Code:
emerge --update --deep --with-bdeps=y --newuse @world
Back to top
View user's profile Send private message
Jack Krauser
Apprentice
Apprentice


Joined: 19 Jan 2011
Posts: 209

PostPosted: Wed Jul 10, 2019 2:33 pm    Post subject: Reply with quote

quilosaq wrote:
Posiblemente estás haciendo una actualización parcial del sistema en lugar de un emerge @world. En esa actualización se está incluyendo dev-libs/boost pero no se está incluyendo algún paquete que está requiriendo precisamente dev-libs/boost-1.65.0:0/1.65.0::gentoo.

Deberías actualizar con:
Code:
emerge --update --deep --with-bdeps=y --newuse @world


Al hacer éste comando conjuntamente con la solución que me propusiste en el otro post e instalar la versión de nodejs que necesitaba y ajustar los paquetes que emerge me pedía pude solucionar éste problema.

quilosaq wrote:
Deberías actualizar con:
Code:
emerge --update --deep --with-bdeps=y --newuse @world


Generalmente mis comando para actualizar portage y el sistema son los siguientes: "emerge --sync" y "emerge -avuND @world"; en qué se diferencia de lo que me recomiendas?

Tengo un problema parecido en otro equipo pero ahora con udisk:
Code:

Total: 1 package (1 reinstall), Size of downloads: 0 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

sys-fs/lvm2:0

  (sys-fs/lvm2-2.02.184-r4:0/0::gentoo, ebuild scheduled for merge) conflicts with
    <sys-fs/lvm2-2.02.183 required by (sys-fs/udisks-1.0.5-r3:0/0::gentoo, installed)


Al desinstalar y volver a instalar tengo lo siguiente:

Code:
[ebuild  N     ] sys-fs/udisks-2.8.2:2::gentoo  USE="acl introspection nls systemd -debug -elogind -lvm (-selinux) -vdo" 0 KiB
[ebuild  N     ] sys-fs/udisks-1.0.5-r3::gentoo  USE="lvm nls -debug -remote-access (-selinux)" 0 KiB

Total: 13 packages (9 upgrades, 2 new, 1 in new slot, 1 reinstall), Size of downloads: 451.641 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

sys-fs/lvm2:0

  (sys-fs/lvm2-2.02.184-r4:0/0::gentoo, ebuild scheduled for merge) conflicts with
    <sys-fs/lvm2-2.02.183 required by (sys-fs/udisks-1.0.5-r3:0/0::gentoo, ebuild scheduled for merge)
    ^            ^^^^^^^^


Hasta el momento no he podido deshacerme del problema. Me puedes echar una mano allí?
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1421

PostPosted: Wed Jul 10, 2019 3:12 pm    Post subject: Reply with quote

Jack Krauser wrote:
...
Generalmente mis comando para actualizar portage y el sistema son los siguientes: "emerge --sync" y "emerge -avuND @world"; en qué se diferencia de lo que me recomiendas?
...
Son bastante parecidos. Las opciones u, N y D de tu comando son equivalentes a las --update, --newuse y --deep respectivamente del que yo uso.

El tuyo además tiene las opciones "a" que hace que te pida confirmación antes de empezar la actualización y "v" que hace que muestre información detallada de los que va haciendo.

El mío tiene la opción --with-bdeps=y que hace que se incluyan en la actualización los paquetes que se van a necesitar en la fase de construcción del resto de paquetes. En la práctica no es una opción que suponga grandes cambios y sobre todo no solucionaría el problema que planeas en este hilo.

El comando que utilizo es el mas completo de los que aparecen en el manuel de Gentoo:
https://wiki.gentoo.org/wiki/Handbook:AMD64/Working/Portage/es#Actualizando_su_sistema
Back to top
View user's profile Send private message
quilosaq
Veteran
Veteran


Joined: 22 Dec 2009
Posts: 1421

PostPosted: Wed Jul 10, 2019 3:34 pm    Post subject: Reply with quote

Jack Krauser wrote:
...
Hasta el momento no he podido deshacerme del problema. Me puedes echar una mano allí?

Parece que cuando quieres instalar udisks se te instalan 2 versiones distintas. Mira si son dependencias para algún paquete que ya tengas instalado:
Code:
equery depends udisks

¿Qué comando ejecutas para instalar udisks?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum