Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]Instalación de Nodejs en Gentoo
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Jack Krauser
Apprentice
Apprentice


Joined: 19 Jan 2011
Posts: 209

PostPosted: Tue Jul 09, 2019 7:43 pm    Post subject: [SOLVED]Instalación de Nodejs en Gentoo Reply with quote

Buenas con todos.

Estoy queriendo usar angular 8 en mi compu de trabajo pero en portage solo está disponible (sin desenmascarar) la versión 8 de node y Angular requiere las versión ^10 y para poder hacer eso tengo que desenmascarar la versión que requiero. Al habilitar las USE necesarias tengo éste error que no sé cómo solucionar:

Code:
emerge -pv nodejs --verbose-conflict

These are the packages that would be merged, in order:

Calculating dependencies /... done!


Exiting on signal Signals.SIGINT
GENTOO-DESKTOP /home/ricardo # emerge -pv nodejs --verbose-conflicts

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U #] dev-libs/openssl-1.1.1c:0/1.1::gentoo [1.0.2r:0/0::gentoo] USE="asm zlib -bindist -rfc3779 -sctp -sslv3* -static-libs -test -tls-heartbeat* -vanilla (-gmp%) (-kerberos%) (-sslv2%)" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="(sse2)" 8.657 KiB
[ebuild  N    ~] net-dns/c-ares-1.15.0:0/2::gentoo  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 1.317 KiB
[ebuild     U ~] net-libs/nodejs-11.14.0::gentoo [8.12.0::gentoo] USE="npm snapshot ssl -debug -doc -icu -inspector -systemtap -test" CPU_FLAGS_X86="sse2" PYTHON_TARGETS="python2_7" 21.589 KiB

Total: 3 packages (2 upgrades, 1 new), Size of downloads: 31.562 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.1.1c:0/1.1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/openssl-1.1.0g:0[bindist=] required by (net-misc/openssh-7.9_p1-r4:0/0::gentoo, installed)
    ^^                 ^^^^^^^^                                                                                                                                                   
    >=dev-libs/openssl-1.1:0= required by (net-libs/nodejs-11.14.0:0/0::gentoo, ebuild scheduled for merge)
    ^^                 ^^^^^^                                                                                                                                                       

  (dev-libs/openssl-1.0.2r:0/0::gentoo, installed) pulled in by
    dev-libs/openssl:0/0= required by (sys-fs/cryfs-0.9.9:0/0::gentoo, installed)
                    ^^^^^                                                                                           
    dev-libs/openssl:0/0= required by (dev-lang/rust-1.34.2:stable/1.34::gentoo, installed)
                    ^^^^^                                                                                                     
    dev-libs/openssl:0/0= required by (dev-db/mysql-connector-c++-1.1.11:0/0::gentoo, installed)
                    ^^^^^                                                                                                           
    dev-libs/openssl:0/0=[-bindist] required by (net-vpn/tor-0.4.0.5:0/0::gentoo, installed)
                    ^^^^^                                                                                                       
    >=dev-libs/openssl-0.9.6-r1:0/0= required by (dev-db/postgresql-11.4:11/11::gentoo, installed)
                               ^^^^^                                                                                                 
    >=dev-libs/openssl-1.0.2j:0/0= required by (media-tv/kodi-17.6-r11:0/0::gentoo, installed)
                             ^^^^^                                                                                               
    dev-libs/openssl:0/0= required by (www-client/lynx-2.8.9_p1:0/0::gentoo, installed)
                    ^^^^^                                                                                                 
    dev-libs/openssl:0/0=[-bindist] required by (dev-qt/qtnetwork-5.12.3:5/5.12::gentoo, installed)
                    ^^^^^                                                                                                             
    dev-libs/openssl:0/0=[abi_x86_64(-)] required by (dev-db/mysql-connector-c-6.1.11-r1:0/18::gentoo, installed)
                    ^^^^^                                                                                                                           
    dev-libs/openssl:0/0=[abi_x86_64(-)] required by (net-libs/neon-0.30.2:0/27::gentoo, installed)
                    ^^^^^                                                                                                             
    >=dev-libs/openssl-1.0.1h-r2:0/0=[abi_x86_64(-)] required by (net-libs/libssh-0.8.6:0/4::gentoo, installed)
                                ^^^^^                                                                                                             
    dev-libs/openssl:0/0=[abi_x86_64(-)] required by (net-misc/curl-7.65.0:0/0::gentoo, installed)
                    ^^^^^                                                                                                             
    dev-libs/openssl:0/0= required by (net-misc/socat-1.7.3.2:0/0::gentoo, installed)
                    ^^^^^                                                                                               
    dev-libs/openssl:0/0= required by (dev-lang/python-3.6.5:3.6/3.6m::gentoo, installed)
                    ^^^^^                                                                                                   
    dev-libs/openssl:0/0=[abi_x86_64(-)] required by (app-arch/libarchive-3.3.3:0/13::gentoo, installed)
                    ^^^^^                                                                                                                   
    >=dev-libs/openssl-1.0.1h-r2:0/0=[abi_x86_64(-)] required by (media-video/ffmpeg-4.1.3:0/56.58.58::gentoo, installed)
                                ^^^^^                                                                                                                       
    dev-libs/openssl:0/0= required by (app-emulation/virtualbox-6.0.8:0/0::gentoo, installed)
                    ^^^^^                                                                                                       
    dev-libs/openssl:0/0= required by (app-admin/apache-tools-2.4.39:0/0::gentoo, installed)
                    ^^^^^                                                                                                       
    dev-libs/openssl:0/0= required by (net-misc/freerdp-2.0.0_rc4:0/2::gentoo, installed)
                    ^^^^^                                                                                                   
    dev-libs/openssl:0/0= required by (dev-perl/Net-SSLeay-1.820.0:0/0::gentoo, installed)
                    ^^^^^                                                                                                     
    dev-libs/openssl:0/0=[abi_x86_64(-)] required by (dev-db/mariadb-connector-c-3.0.6-r1:0/3::gentoo, installed)
                    ^^^^^                                                                                                                           
    dev-libs/openssl:0/0= required by (media-sound/spotify-1.1.5-r1:0/0::gentoo, installed)
                    ^^^^^                                                                                                     
    dev-libs/openssl:0/0= required by (net-misc/remmina-1.2.31.3:0/0::gentoo, installed)
                    ^^^^^                                                                                                   
    dev-libs/openssl:0/0= required by (net-misc/dhcp-4.4.1:0/0::gentoo, installed)
                    ^^^^^                                                                                             
    dev-libs/openssl:0/0= required by (dev-python/m2crypto-0.31.0-r2:0/0::gentoo, installed)
                    ^^^^^                                                                                                       
    dev-libs/openssl:0/0= required by (x11-base/xorg-server-1.20.4:0/1.20.4::gentoo, installed)
                    ^^^^^                                                                                                         
    dev-libs/openssl:0/0= required by (net-misc/iputils-20180629:0/0::gentoo, installed)
                    ^^^^^                                                                                                   
    dev-libs/openssl:0/0=[abi_x86_64(-)] required by (app-crypt/rhash-1.3.6-r1:0/0::gentoo, installed)
                    ^^^^^                                                                                                                 
    dev-libs/openssl:0/0= required by (dev-python/cryptography-2.6.1:0/0::gentoo, installed)
                    ^^^^^                                                                                                       
    >=dev-libs/openssl-1.0.1c:0/0= required by (www-servers/nginx-1.17.1:mainline/mainline::gentoo, installed)
                             ^^^^^                                                                                                               
    >=dev-libs/openssl-1.0.1h-r2:0/0=[abi_x86_64(-)] required by (app-crypt/mit-krb5-1.16-r2:0/0::gentoo, installed)
                                ^^^^^                                                                                                                   
    dev-libs/openssl:0/0= required by (media-sound/pulseaudio-12.2-r1:0/0::gentoo, installed)
                    ^^^^^                                                                                                       
    >=dev-libs/openssl-1.0.1h-r2:0/0=[abi_x86_64(-)] required by (dev-libs/libevent-2.1.8:0/2.1-6::gentoo, installed)
                                ^^^^^                                                                                                                   
    dev-libs/openssl:0/0= required by (net-libs/gsoap-2.8.70:0/0::gentoo, installed)
                    ^^^^^                                                                                               
    dev-libs/openssl:0/0= required by (dev-libs/libzip-1.5.1:0/5::gentoo, installed)
                    ^^^^^                                                                                               
    dev-libs/openssl:0/0= required by (net-libs/c-client-2007f-r6:0/0::gentoo, installed)
                    ^^^^^                                                                                                   
    >=dev-libs/openssl-1.0.1:0/0= required by (dev-lang/php-7.3.7:7.3/7.3::gentoo, installed)
                            ^^^^^                                                                                               
    dev-libs/openssl:0/0= required by (dev-libs/xmlsec-1.2.28:0/0::gentoo, installed)
                    ^^^^^                                                                                               
    dev-libs/openssl:0/0= required by (dev-vcs/git-2.21.0:0/0::gentoo, installed)
                    ^^^^^                                                                                           
    dev-libs/openssl:0/0= required by (dev-lang/ruby-2.4.6:2.4/2.4::gentoo, installed)
                    ^^^^^                                                                                                 
    dev-libs/openssl:0/0= required by (net-misc/tigervnc-1.9.0-r1:0/0::gentoo, installed)
                    ^^^^^                                                                                                   
    dev-libs/openssl:0/0= required by (dev-lang/python-2.7.15:2.7/2.7::gentoo, installed)
                    ^^^^^                                                                                                   
    dev-libs/openssl:0/0= required by (net-libs/libeXosip-4.0.0:0/4.0::gentoo, installed)
                    ^^^^^                                                                                                   
    dev-libs/openssl:0/0= required by (net-wireless/crda-3.18-r3:0/0::gentoo, installed)
                    ^^^^^                                                                                                   
    >=dev-libs/openssl-1.0.1:0/0= required by (app-crypt/qca-2.2.0:2/2::gentoo, installed)
                            ^^^^^                                                                                             
    dev-libs/openssl:0/0= required by (net-misc/openssh-7.9_p1-r4:0/0::gentoo, installed)
                    ^^^^^                                                                                                   
    >=dev-libs/openssl-1.0.2:0/0=[-bindist,abi_x86_64(-)] required by (net-libs/nghttp2-1.39.1:0/1.14::gentoo, installed)
                            ^^^^^                                                                                                                           
    >=dev-libs/openssl-1.0.2:0/0=[abi_x86_64(-)] required by (net-libs/libvncserver-0.9.12:0/0::gentoo, installed)
                            ^^^^^                                                                                                                     
    dev-libs/openssl:0/0= required by (www-servers/nginx-1.17.1:mainline/mainline::gentoo, installed)
                    ^^^^^                                                                                                               
    dev-libs/openssl:0/0= required by (net-libs/ortp-0.23.0-r1:0/9::gentoo, installed)
                    ^^^^^                                                                                                 
    dev-libs/openssl:0/0= required by (net-dialup/ppp-2.4.7-r7:0/2.4.7::gentoo, installed)
                    ^^^^^                                                                                                     
    >=dev-libs/openssl-1.0.1h-r2:0/0=[abi_x86_64(-)] required by (dev-libs/cyrus-sasl-2.1.27-r2:2/2::gentoo, installed)
                                ^^^^^                                                                                                                     
    >=dev-libs/openssl-1.0.1h-r2:0/0=[abi_x86_64(-)] required by (net-nds/openldap-2.4.45:0/0::gentoo, installed)
                                ^^^^^                                                                                                               
    dev-libs/openssl:0/0= required by (net-voip/linphone-3.6.1:0/0::gentoo, installed)
                    ^^^^^                                                                                                 
    >=dev-libs/openssl-1.0.2k:0/0=[-bindist] required by (net-wireless/wpa_supplicant-2.6-r10:0/0::gentoo, installed)
                             ^^^^^                                                                                                                       
    dev-libs/openssl:0/0= required by (sys-fs/cryptsetup-2.1.0:0/12::gentoo, installed)
                    ^^^^^                                                                                                 
    dev-libs/openssl:0/0= required by (net-misc/wget-1.20.3-r1:0/0::gentoo, installed)
                    ^^^^^                                                                                                 
    >=dev-libs/openssl-1.0.2:0/0= required by (www-servers/apache-2.4.39:2/2::gentoo, installed)
                            ^^^^^                                                                                                   
    >=dev-libs/openssl-1.0.1h-r2:0/0=[abi_x86_64(-)] required by (net-libs/libssh2-1.8.2:0/0::gentoo, installed)
                                ^^^^^                                                                                                               
    dev-libs/openssl:0/0= required by (x11-misc/x11vnc-0.9.16-r2:0/0::gentoo, installed)
                    ^^^^^                                                                                                   


!!! The slot conflict(s) shown above involve package(s) which may need to
!!! be rebuilt in order to solve the conflict(s). However, the following
!!! package(s) cannot be rebuilt for the reason(s) shown:

  (net-libs/libeXosip-4.0.0:0/4.0::gentoo, installed): ebuild is masked or unavailable
  (net-voip/linphone-3.6.1:0/0::gentoo, installed): ebuild is masked or unavailable



Espero me puedan echar una mano en ésto :oops:


Last edited by Jack Krauser on Wed Jul 10, 2019 1:48 pm; edited 1 time in total
Back to top
View user's profile Send private message
Jack Krauser
Apprentice
Apprentice


Joined: 19 Jan 2011
Posts: 209

PostPosted: Wed Jul 10, 2019 1:48 pm    Post subject: Reply with quote

Parece que el problema es con la versión de node -> net-libs/nodejs-11.14.0

Al instalar la versión 10.15.3 disponible en portage (y después de haber instalado lo que emerge me pedía) pude instalar la versión que necesito para poder ejecutar Angular 8
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum