Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto]Database personale degli appunti
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
ilnanny
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jul 2017
Posts: 98
Location: Italy/Taranto

PostPosted: Sat Apr 13, 2019 10:29 am    Post subject: [Risolto]Database personale degli appunti Reply with quote

Ciao ,questo topic è piu' che altro una richiesta di aiuto personale.
Vengo al punto ;ho da sempre utilizzato i manuali ,libri cartacei e appunti su carta e poi in digitale ,in semplici file di testo ,odt e pdf .
Ultimamente ho fatto una cernita di tutto ciò che mi può tornare utile (offline) e ho cercato di dare un senso alla cartella dei file di appunti e piccoli how-to ,perchè tendo a dimenticare anche i comandi o alcune configurazioni . Detto questo la domanda vera e propria è :
Ci sarebbe un modo per racchiudere tutti i miei 'pizzini' in un database locale ,richiamandolo magari da termianle tramite parole chiave .es:
scrivo 'info-portage ' e mi ritorna una lista di file che hanno come prima parola del titolo 'portage'.
O ancor meglio se si potesse creare (sempre in locale )una sorta di wiki da sfogliare facilmente .
Sò che la richiesta è un pò strana e magari spiegata in maniera errata ,ma magari c'è qualcuno che potrebbe darmi una mano .
n.b.= per i Moderatori
se il topic è fuori luogo ,lo elimino .
Grazie anticipatamente .e comunque.
_______
** scrivo la lettera 'u' accentata in quel modo perchè per qualche strano motivo o stregoneria non funziona piu' l'accentata sulla tastiera :D
_________________
== Lila-HD-icon-theme ==
https://github.com/ilnanny/Lila-HD-icon-theme


Last edited by ilnanny on Sat Apr 13, 2019 10:54 am; edited 1 time in total
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 689

PostPosted: Sat Apr 13, 2019 10:39 am    Post subject: Reply with quote

tellico

Code:
kde-misc/tellico
     Available versions:  (5) 3.1.4^t
       {cddb debug discid +handbook pdf scanner semantic-desktop taglib test v4l xmp yaz}
     Installed versions:  3.1.4(5)^t(19:48:56 29/12/2018)(cddb handbook pdf scanner v4l -debug -discid -semantic-desktop -taglib -test -xmp -yaz)
     Homepage:            http://tellico-project.org/
     Description:         Collection manager based on KDE Frameworks


Personalizzabile.

Un raccoglitore di pdf,ebook e quant,altro ... butta un occhio anche a calibre

Code:

app-text/calibre
     Available versions:  3.26.1 (~)3.38.1 (~)3.40.1 {ios +udisks PYTHON_TARGETS="python2_7"}
     Installed versions:  3.26.1(23:19:55 05/02/2019)(udisks -ios PYTHON_TARGETS="python2_7")
     Homepage:            https://calibre-ebook.com/
     Description:         Ebook management application


O se vuoi stare nel generico , ma ci devi mettere del tuo , un database con BASE di LibreOffice ...
_________________
BOINC ed il calcolo distribuito

My LiveRecoverySystem Repo
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21549
Location: here

PostPosted: Sat Apr 13, 2019 10:45 am    Post subject: Reply with quote

Personalmente uso calibre per gli ebook, tellico e piu' generale per qualsiasi collezione (dvd, cd,...)
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ilnanny
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jul 2017
Posts: 98
Location: Italy/Taranto

PostPosted: Sat Apr 13, 2019 10:51 am    Post subject: Reply with quote

Grazie mille ad entrambe ,provo ad installare i due software sperando che non si portino dietro mezza kde .(utilizzo xfce su un pc abbastanza datato) e cercherò di capire anche un pò anche il database di libreoffice che non ho mai utilizzato .
Grazie mille ancora.
_________________
== Lila-HD-icon-theme ==
https://github.com/ilnanny/Lila-HD-icon-theme
Back to top
View user's profile Send private message
ilnanny
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jul 2017
Posts: 98
Location: Italy/Taranto

PostPosted: Sat Apr 13, 2019 11:03 am    Post subject: Reply with quote

mi sà che opterò per libreoffice ,gli altri due software hanno bisogno dei kde-frameworks per funzionare :(
_________________
== Lila-HD-icon-theme ==
https://github.com/ilnanny/Lila-HD-icon-theme
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21549
Location: here

PostPosted: Sat Apr 13, 2019 11:16 am    Post subject: Reply with quote

ilnanny wrote:
mi sà che opterò per libreoffice ,gli altri due software hanno bisogno dei kde-frameworks per funzionare :(

Per tellico hai ragione ma calibre usa solo le librerie qt ma non il kde-frameworks
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ilnanny
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jul 2017
Posts: 98
Location: Italy/Taranto

PostPosted: Sat Apr 13, 2019 11:44 am    Post subject: Reply with quote

fedeliallalinea wrote:

Per tellico hai ragione ma calibre usa solo le librerie qt ma non il kde-frameworks

Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-libs/chmlib-0.40-r1  USE="examples -static-libs"
[ebuild  N     ] dev-python/sip-4.19.13  USE="-debug -doc" PYTHON_TARGETS="python2_7 python3_6 -python3_5 (-python3_7)"
[ebuild  N     ] dev-python/apsw-3.23.1_p1  USE="-doc" PYTHON_TARGETS="python2_7 python3_6 -python3_5"
[ebuild  N     ] dev-python/beautifulsoup-3.2.1-r1  PYTHON_TARGETS="python2_7 (-pypy)"
[ebuild  N     ] dev-python/regex-2017.04.05  USE="-doc" PYTHON_TARGETS="python2_7 python3_6 (-pypy) -python3_5 (-python3_7)"
[ebuild  N     ] dev-python/cssselect-0.9.1  USE="-doc -test" PYTHON_TARGETS="python2_7 python3_6 -python3_5"
[ebuild  N     ] dev-python/cssutils-1.0.1  USE="-test" PYTHON_TARGETS="python2_7 python3_6 (-pypy) -python3_5"
[ebuild  N     ] dev-python/mechanize-0.2.5-r1  USE="-doc" PYTHON_TARGETS="python2_7 (-pypy)"
[ebuild  N     ] dev-python/netifaces-0.10.6  PYTHON_TARGETS="python2_7 python3_6 (-pypy) (-pypy3) -python3_5"
[ebuild  N     ] dev-python/psutil-5.5.0  USE="-test" PYTHON_TARGETS="python2_7 python3_6 (-pypy) (-pypy3) -python3_5 (-python3_7)"
[ebuild  N     ] dev-python/pygments-2.2.0  USE="-doc -test" PYTHON_TARGETS="python2_7 python3_6 (-pypy) (-pypy3) -python3_5 (-python3_7)"
[ebuild  N     ] dev-python/setuptools_scm-1.15.6-r1  USE="-git -mercurial -test" PYTHON_TARGETS="python2_7 python3_6 (-pypy) (-pypy3) -python3_5"
[ebuild  N     ] dev-python/cython-0.25.2  USE="-doc -emacs -test" PYTHON_TARGETS="python2_7 python3_6 -python3_5"
[ebuild  N     ] dev-python/html5-parser-0.4.4-r1  PYTHON_TARGETS="python2_7 python3_6 -python3_5"
[ebuild  N     ] dev-python/msgpack-0.5.1  USE="-test" PYTHON_TARGETS="python2_7 python3_6 -python3_5 (-python3_7)"
[ebuild  N     ] dev-python/python-dateutil-2.7.2-r1  USE="-test" PYTHON_TARGETS="python2_7 python3_6 (-pypy) (-pypy3) -python3_5 (-python3_7)"
[ebuild  N     ] dev-python/dbus-python-1.2.4  USE="-doc -examples -test" PYTHON_TARGETS="python2_7 python3_6 -python3_5"
[ebuild  N     ] app-text/podofo-0.9.6_pre20170508-r1  USE="boost tools -debug -idn -libressl -test"
[ebuild  N     ] virtual/podofo-build-0.9.6_pre20170508-r1  USE="boost tools -debug -idn -test"
[ebuild  N     ] media-libs/gst-plugins-good-1.14.4  USE="nls orc" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-qt/qtbluetooth-5.11.3  USE="-debug -qml -test"
[ebuild  N     ] media-plugins/gst-plugins-gtk-1.14.4  USE="X egl opengl -gles2 -wayland" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] media-libs/gst-plugins-bad-1.14.3  USE="X bzip2 egl gtk introspection nls opengl orc -gles2 -test -vcd -vnc -wayland" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-qt/qtwebkit-5.212.0_pre20180120  USE="X gstreamer hyphen jit opengl printsupport -geolocation (-gles2) -multimedia -nsplugin -orientation -qml -webp"
[ebuild  N     ] dev-python/PyQt5-5.10.1-r1  USE="bluetooth dbus gui network opengl printsupport svg webkit widgets -debug -declarative -designer -examples (-gles2) -help -location -multimedia -positioning -sensors -serialport -sql -testlib -webchannel -webengine -websockets -x11extras -xmlpatterns" PYTHON_TARGETS="python2_7 python3_6 -python3_5 (-python3_7)"
[ebuild  N     ] dev-python/pycrypto-2.6.1-r2  USE="gmp -doc -test" PYTHON_TARGETS="python2_7 python3_6 -python3_5 (-python3_7)"
[uninstall     ] dev-python/pycryptodome-3.6.6
[blocks b      ] dev-python/pycrypto ("dev-python/pycrypto" is blocking dev-python/pycryptodome-3.6.6)
[ebuild  N     ] dev-python/dnspython-1.15.0-r1  USE="-examples -test" PYTHON_TARGETS="python2_7 python3_6 -python3_5"
[ebuild  N     ] virtual/python-dnspython-2  PYTHON_TARGETS="python2_7 python3_6 -python3_5"
[ebuild  N     ] app-text/calibre-3.26.1  USE="udisks -ios" PYTHON_TARGETS="python2_7"


però dai ,lo stò installando per provare ,anche perchè per libreoffice db dovrei ricompilarlo con la 'use flag java' per avere le funzionalita aggiuntive,da quel poco che ho capito sul loro forum ,perchè non riesco ad inserire la versione installata di openjdk.Mbo.?
Code:
java -version
openjdk version "1.8.0_191"
OpenJDK Runtime Environment (IcedTea 3.10.0) (Gentoo icedtea-3.10.0)
OpenJDK 64-Bit Server VM (build 25.191-b12, mixed mode)


Infatti quando provo a creare un nuovo database di prova mi restituisce questo errore :
Code:

Impossibile stabilire il collegamento alla sorgente dati esterna in quanto non è stato trovato il driver SDBC per l'indirizzo URL 'sdbc:embedded:hsqldb'.

Vedo come funziona Calibre ,magari sarà pi semplice anche per uno gnucco come me :D
_________________
== Lila-HD-icon-theme ==
https://github.com/ilnanny/Lila-HD-icon-theme
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21549
Location: here

PostPosted: Sat Apr 13, 2019 12:22 pm    Post subject: Reply with quote

Non ho capito bene per libreoffice ma sembra che bisogna anche usare la versione di hsqldb fornita in libreoffice perche' quella in portage e' troppo nuova
Code:
       if use java; then
                # hsqldb: system one is too new
                myeconfargs+=(
                        --without-junit
                        --without-system-hsqldb
                        --with-ant-home="${ANT_HOME}"
                        --with-jdk-home=$(java-config --jdk-home 2>/dev/null)
                        --with-jvm-path="${EPREFIX}/usr/lib/"
                )

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ilnanny
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jul 2017
Posts: 98
Location: Italy/Taranto

PostPosted: Sat Apr 13, 2019 3:08 pm    Post subject: Reply with quote

si infatti ho lasciato perdere per libreoffice ,un pò troppo complicato ,per cimentarmi in qualcosa che non mi interessa poi così tanto .
./
Il problema adesso e che non riesco a compilare PyQt5 [calibre] :
Code:
Calculating dependencies... done!
 * emerge --keep-going: app-text/calibre-3.26.1 dropped because it requires
 * virtual/python-dnspython[python_targets_python2_7(-),-python_single_target_
 * jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-
 * python_single_target_python3_5(-),-python_single_target_python3_6(-),-pytho
 * n_single_target_python3_7(-),python_single_target_python2_7(+)],
 * virtual/python-dnspython[python_targets_python2_7(-),-python_single_target_
 * jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-
 * python_single_target_python3_5(-),-python_single_target_python3_6(-),-pytho
 * n_single_target_python3_7(-),python_single_target_python2_7(+)],
 * >=virtual/podofo-build-0.9.4, dev-python/sip[python_targets_python2_7(-),-p
 * ython_single_target_jython2_7(-),-python_single_target_pypy(-),-python_sing
 * le_target_pypy3(-),-python_single_target_python3_5(-),-python_single_target
 * _python3_6(-),-python_single_target_python3_7(-),python_single_target_pytho
 * n2_7(+)], dev-python/regex[python_targets_python2_7(-),-python_single_targe
 * t_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-)
 * ,-python_single_target_python3_5(-),-python_single_target_python3_6(-),-pyt
 * hon_single_target_python3_7(-),python_single_target_python2_7(+)], >=dev-py
 * thon/PyQt5-5.8[gui,svg,webkit,widgets,network,printsupport,python_targets_p
 * ython2_7(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-
 * ),-python_single_target_pypy3(-),-python_single_target_python3_5(-),-python
 * _single_target_python3_6(-),-python_single_target_python3_7(-),python_singl
 * e_target_python2_7(+)], >=dev-python/python-dateutil-2.5.3[python_targets_p
 * ython2_7(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-
 * ),-python_single_target_pypy3(-),-python_single_target_python3_5(-),-python
 * _single_target_python3_6(-),-python_single_target_python3_7(-),python_singl
 * e_target_python2_7(+)], >=dev-python/pygments-2.1.3[python_targets_python2_
 * 7(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-pyth
 * on_single_target_pypy3(-),-python_single_target_python3_5(-),-python_single
 * _target_python3_6(-),-python_single_target_python3_7(-),python_single_targe
 * t_python2_7(+)], dev-python/psutil[python_targets_python2_7(-),-python_sing
 * le_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_
 * pypy3(-),-python_single_target_python3_5(-),-python_single_target_python3_6
 * (-),-python_single_target_python3_7(-),python_single_target_python2_7(+)],
 * dev-python/netifaces[python_targets_python2_7(-),-python_single_target_jyth
 * on2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-pyth
 * on_single_target_python3_5(-),-python_single_target_python3_6(-),-python_si
 * ngle_target_python3_7(-),python_single_target_python2_7(+)], dev-python/msg
 * pack[python_targets_python2_7(-),-python_single_target_jython2_7(-),-python
 * _single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target
 * _python3_5(-),-python_single_target_python3_6(-),-python_single_target_pyth
 * on3_7(-),python_single_target_python2_7(+)], >=dev-python/mechanize-0.2.5[p
 * ython_targets_python2_7(-),-python_single_target_jython2_7(-),-python_singl
 * e_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_pytho
 * n3_5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(
 * -),python_single_target_python2_7(+)], dev-python/html5-parser[python_targe
 * ts_python2_7(-),-python_single_target_jython2_7(-),-python_single_target_py
 * py(-),-python_single_target_pypy3(-),-python_single_target_python3_5(-),-py
 * thon_single_target_python3_6(-),-python_single_target_python3_7(-),python_s
 * ingle_target_python2_7(+)], >=dev-python/dbus-python-1.2.4[python_targets_p
 * ython2_7(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-
 * ),-python_single_target_pypy3(-),-python_single_target_python3_5(-),-python
 * _single_target_python3_6(-),-python_single_target_python3_7(-),python_singl
 * e_target_python2_7(+)], >=dev-python/cssutils-1.0.1[python_targets_python2_
 * 7(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-pyth
 * on_single_target_pypy3(-),-python_single_target_python3_5(-),-python_single
 * _target_python3_6(-),-python_single_target_python3_7(-),python_single_targe
 * t_python2_7(+)], >=dev-python/cssselect-0.7.1[python_targets_python2_7(-),-
 * python_single_target_jython2_7(-),-python_single_target_pypy(-),-python_sin
 * gle_target_pypy3(-),-python_single_target_python3_5(-),-python_single_targe
 * t_python3_6(-),-python_single_target_python3_7(-),python_single_target_pyth
 * on2_7(+)], >=dev-python/beautifulsoup-3.0.5:python-2[python_targets_python2
 * _7(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-pyt
 * hon_single_target_pypy3(-),-python_single_target_python3_5(-),-python_singl
 * e_target_python3_6(-),-python_single_target_python3_7(-),python_single_targ
 * et_python2_7(+)], >=dev-python/apsw-3.13.0[python_targets_python2_7(-),-pyt
 * hon_single_target_jython2_7(-),-python_single_target_pypy(-),-python_single
 * _target_pypy3(-),-python_single_target_python3_5(-),-python_single_target_p
 * ython3_6(-),-python_single_target_python3_7(-),python_single_target_python2
 * _7(+)], >=dev-libs/chmlib-0.40:=, >=app-text/podofo-0.8.2:=, dev-python/reg
 * ex[python_targets_python2_7(-),-python_single_target_jython2_7(-),-python_s
 * ingle_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_p
 * ython3_5(-),-python_single_target_python3_6(-),-python_single_target_python
 * 3_7(-),python_single_target_python2_7(+)], >=dev-python/PyQt5-5.8[gui,svg,w
 * ebkit,widgets,network,printsupport,python_targets_python2_7(-),-python_sing
 * le_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_
 * pypy3(-),-python_single_target_python3_5(-),-python_single_target_python3_6
 * (-),-python_single_target_python3_7(-),python_single_target_python2_7(+)],
 * >=dev-python/python-dateutil-2.5.3[python_targets_python2_7(-),-python_sing
 * le_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_
 * pypy3(-),-python_single_target_python3_5(-),-python_single_target_python3_6
 * (-),-python_single_target_python3_7(-),python_single_target_python2_7(+)],
 * >=dev-python/pygments-2.1.3[python_targets_python2_7(-),-python_single_targ
 * et_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-
 * ),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-py
 * thon_single_target_python3_7(-),python_single_target_python2_7(+)], dev-pyt
 * hon/psutil[python_targets_python2_7(-),-python_single_target_jython2_7(-),-
 * python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_
 * target_python3_5(-),-python_single_target_python3_6(-),-python_single_targe
 * t_python3_7(-),python_single_target_python2_7(+)], dev-python/netifaces[pyt
 * hon_targets_python2_7(-),-python_single_target_jython2_7(-),-python_single_
 * target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python3
 * _5(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-)
 * ,python_single_target_python2_7(+)], dev-python/msgpack[python_targets_pyth
 * on2_7(-),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-
 * python_single_target_pypy3(-),-python_single_target_python3_5(-),-python_si
 * ngle_target_python3_6(-),-python_single_target_python3_7(-),python_single_t
 * arget_python2_7(+)], >=dev-python/mechanize-0.2.5[python_targets_python2_7(
 * -),-python_single_target_jython2_7(-),-python_single_target_pypy(-),-python
 * _single_target_pypy3(-),-python_single_target_python3_5(-),-python_single_t
 * arget_python3_6(-),-python_single_target_python3_7(-),python_single_target_
 * python2_7(+)], dev-python/html5-parser[python_targets_python2_7(-),-python_
 * single_target_jython2_7(-),-python_single_target_pypy(-),-python_single_tar
 * get_pypy3(-),-python_single_target_python3_5(-),-python_single_target_pytho
 * n3_6(-),-python_single_target_python3_7(-),python_single_target_python2_7(+
 * )], >=dev-python/dbus-python-1.2.4[python_targets_python2_7(-),-python_sing
 * le_target_jython2_7(-),-python_single_target_pypy(-),-python_single_target_
 * pypy3(-),-python_single_target_python3_5(-),-python_single_target_python3_6
 * (-),-python_single_target_python3_7(-),python_single_target_python2_7(+)],
 * >=dev-python/cssutils-1.0.1[python_targets_python2_7(-),-python_single_targ
 * et_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-
 * ),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-py
 * thon_single_target_python3_7(-),python_single_target_python2_7(+)], >=dev-p
 * ython/cssselect-0.7.1[python_targets_python2_7(-),-python_single_target_jyt
 * hon2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-pyt
 * hon_single_target_python3_5(-),-python_single_target_python3_6(-),-python_s
 * ingle_target_python3_7(-),python_single_target_python2_7(+)], >=dev-python/
 * beautifulsoup-3.0.5:python-2[python_targets_python2_7(-),-python_single_tar
 * get_jython2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(
 * -),-python_single_target_python3_5(-),-python_single_target_python3_6(-),-p
 * ython_single_target_python3_7(-),python_single_target_python2_7(+)], >=dev-
 * python/apsw-3.13.0[python_targets_python2_7(-),-python_single_target_jython
 * 2_7(-),-python_single_target_pypy(-),-python_single_target_pypy3(-),-python
 * _single_target_python3_5(-),-python_single_target_python3_6(-),-python_sing
 * le_target_python3_7(-),python_single_target_python2_7(+)], >=dev-
 * libs/chmlib-0.40:=, >=app-text/podofo-0.8.2:=

 * Error messages for package dev-python/PyQt5-5.10.1-r1:

 * ERROR: dev-python/PyQt5-5.10.1-r1::gentoo failed (configure phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line  124:  Called src_configure
 *   environment, line 2537:  Called python_foreach_impl 'run_in_build_dir' 'configuration'
 *   environment, line 2003:  Called multibuild_foreach_variant '_python_multibuild_wrapper' 'run_in_build_dir' 'configuration'
 *   environment, line 1365:  Called _multibuild_run '_python_multibuild_wrapper' 'run_in_build_dir' 'configuration'
 *   environment, line 1363:  Called _python_multibuild_wrapper 'run_in_build_dir' 'configuration'
 *   environment, line  480:  Called run_in_build_dir 'configuration'
 *   environment, line 2519:  Called configuration
 *   environment, line 2534:  Called die
 * The specific snippet of code:
 *           "${myconf[@]}" || die;
 *
 * If you need support, post the output of `emerge --info '=dev-python/PyQt5-5.10.1-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-python/PyQt5-5.10.1-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-python/PyQt5-5.10.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/PyQt5-5.10.1-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-python/PyQt5-5.10.1-r1/work/PyQt5_gpl-5.10.1-python2_7'
 * S: '/var/tmp/portage/dev-python/PyQt5-5.10.1-r1/work/PyQt5_gpl-5.10.1'
 *
 * The following 2 packages have failed to build, install, or execute
 * postinst:
 *
 *  (dev-python/PyQt5-5.10.1-r1:0/0::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/dev-python/PyQt5-5.10.1-r1/temp/build.log'
 *  (app-text/calibre-3.26.1:0/0::gentoo, ebuild scheduled for merge)
 *

 * GNU info directory index is up-to-date.


output di /var/tmp/portage/dev-python/PyQt5-5.10.1-r1/temp/build.log

Code:
 * Package:    dev-python/PyQt5-5.10.1-r1
 * Repository: gentoo
 * Maintainer: qt@gentoo.org
 * Upstream:   phil@riverbankcomputing.com pyqt@riverbankcomputing.com
 * USE:        abi_x86_64 amd64 bluetooth dbus elibc_glibc gui kernel_linux network opengl printsupport python_targets_python2_7 python_targets_python3_6 svg userland_GNU webkit widgets
 * FEATURES:   network-sandbox preserve-libs sandbox usersandbox
>>> Unpacking source...
>>> Unpacking PyQt5_gpl-5.10.1.tar.gz to /var/tmp/portage/dev-python/PyQt5-5.10.1-r1/work
>>> Source unpacked in /var/tmp/portage/dev-python/PyQt5-5.10.1-r1/work
>>> Preparing source in /var/tmp/portage/dev-python/PyQt5-5.10.1-r1/work/PyQt5_gpl-5.10.1 ...
 * Applying PyQt5-5.10.1-timeline.patch ...
 [ ok ]
 * Applying PyQt5-5.10.1-fix-testlib.patch ...
 [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-python/PyQt5-5.10.1-r1/work/PyQt5_gpl-5.10.1 ...
 * python2_7: running run_in_build_dir configuration
/usr/bin/python2.7 /var/tmp/portage/dev-python/PyQt5-5.10.1-r1/work/PyQt5_gpl-5.10.1/configure.py --verbose --confirm-license --qmake=/usr/lib64/qt5/bin/qmake --bindir=/usr/bin --destdir=/usr/lib64/python2.7/site-packages --sip-incdir=/usr/include/python2.7 --qsci-api --enable=QtCore --enable=QtXml --enable=QtBluetooth --enable=QtDBus --no-qml-plugin --no-designer-plugin --enable=QtGui --enable=_QOpenGLFunctions_2_0 --enable=_QOpenGLFunctions_2_1 --enable=_QOpenGLFunctions_4_1_Core --enable=QtNetwork --enable=QtOpenGL --enable=QtPrintSupport --enable=QtSvg --enable=QtWebKit --enable=QtWebKitWidgets --enable=QtWidgets
Error: Failed to determine the detail of your Qt installation. Try again using
the --verbose flag to see more detail about the problem.
Querying qmake about your Qt installation...
Determining the details of your Qt installation...
/usr/lib64/qt5/bin/qmake -o cfgtest_QtCore.mk cfgtest_QtCore.pro
Info: creating stash file /var/tmp/portage/dev-python/PyQt5-5.10.1-r1/work/PyQt5_gpl-5.10.1-python2_7/.qmake.stash
make -f cfgtest_QtCore.mk
g++ -c -pipe -O2 -Wall -W -D_REENTRANT -fPIC -DQT_NO_DEBUG -DQT_CORE_LIB -I. -isystem /usr/include/python2.7 -isystem /usr/include/qt5 -isystem /usr/include/qt5/QtCore -I. -I/usr/lib64/qt5/mkspecs/linux-g++ -o cfgtest_QtCore.o ../PyQt5_gpl-5.10.1/config-tests/cfgtest_QtCore.cpp
../PyQt5_gpl-5.10.1/config-tests/cfgtest_QtCore.cpp:1:10: fatal error: sip.h: No such file or directory
 #include <sip.h>
          ^~~~~~~
compilation terminated.
make: *** [cfgtest_QtCore.mk:412: cfgtest_QtCore.o] Error 1
 * ERROR: dev-python/PyQt5-5.10.1-r1::gentoo failed (configure phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line  124:  Called src_configure
 *   environment, line 2537:  Called python_foreach_impl 'run_in_build_dir' 'configuration'
 *   environment, line 2003:  Called multibuild_foreach_variant '_python_multibuild_wrapper' 'run_in_build_dir' 'configuration'
 *   environment, line 1365:  Called _multibuild_run '_python_multibuild_wrapper' 'run_in_build_dir' 'configuration'
 *   environment, line 1363:  Called _python_multibuild_wrapper 'run_in_build_dir' 'configuration'
 *   environment, line  480:  Called run_in_build_dir 'configuration'
 *   environment, line 2519:  Called configuration
 *   environment, line 2534:  Called die
 * The specific snippet of code:
 *           "${myconf[@]}" || die;
 *
 * If you need support, post the output of `emerge --info '=dev-python/PyQt5-5.10.1-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-python/PyQt5-5.10.1-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-python/PyQt5-5.10.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/PyQt5-5.10.1-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-python/PyQt5-5.10.1-r1/work/PyQt5_gpl-5.10.1-python2_7'
 * S: '/var/tmp/portage/dev-python/PyQt5-5.10.1-r1/work/PyQt5_gpl-5.10.1'

_________________
== Lila-HD-icon-theme ==
https://github.com/ilnanny/Lila-HD-icon-theme
Back to top
View user's profile Send private message
ilnanny
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jul 2017
Posts: 98
Location: Italy/Taranto

PostPosted: Sat Apr 13, 2019 3:11 pm    Post subject: Reply with quote

provo -
installo manualmente
dev-python/dnspython-1.15.0-r1
e ri-controllo il log .
/
Edit .
Tutto installato correttamente
_________________
== Lila-HD-icon-theme ==
https://github.com/ilnanny/Lila-HD-icon-theme


Last edited by ilnanny on Sun Apr 14, 2019 9:04 am; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21549
Location: here

PostPosted: Sat Apr 13, 2019 4:13 pm    Post subject: Reply with quote

Puoi postare l'output del comando
Code:
# emerge -pvq dev-python/PyQt5 dev-python/sip

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ilnanny
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jul 2017
Posts: 98
Location: Italy/Taranto

PostPosted: Sun Apr 14, 2019 9:01 am    Post subject: Reply with quote

fedeliallalinea wrote:
Puoi postare l'output del comando
Code:
# emerge -pvq dev-python/PyQt5 dev-python/sip

=
Code:
[ebuild   R   ] dev-python/sip-4.19.13  USE="-debug -doc" PYTHON_TARGETS="python2_7 python3_6 -python3_5 (-python3_7)"
[ebuild   R   ] dev-python/PyQt5-5.10.1-r1  USE="bluetooth dbus gui network opengl printsupport svg webkit widgets -debug -declarative -designer -examples (-gles2) -help -location -multimedia -positioning -sensors -serialport -sql -testlib -webchannel -webengine -websockets -x11extras -xmlpatterns" PYTHON_TARGETS="python2_7 python3_6 -python3_5 (-python3_7)"

Scusa il ritardo nella risposta .
Comunque dopo aver compilato prima ''dnspython'
è andato tutto al suo posto .
L'unica cosa che mi risultava strana era il formato dell'output di errore .
_________________
== Lila-HD-icon-theme ==
https://github.com/ilnanny/Lila-HD-icon-theme
Back to top
View user's profile Send private message
Massimog
Apprentice
Apprentice


Joined: 04 Nov 2011
Posts: 152
Location: Osimo(AN)

PostPosted: Mon Apr 15, 2019 8:45 am    Post subject: Reply with quote

Mi puoi dire se calibre a te mostra le copertine dei libri?
_________________
Distribuzione: Gentoo x86_64
Desktop: GNOME 3.30.2
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21549
Location: here

PostPosted: Mon Apr 15, 2019 9:59 am    Post subject: Reply with quote

Massimog wrote:
Mi puoi dire se calibre a te mostra le copertine dei libri?

Si, ma se ti mancano puoi aggiungere un jpg nella cartella del libro
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Massimog
Apprentice
Apprentice


Joined: 04 Nov 2011
Posts: 152
Location: Osimo(AN)

PostPosted: Mon Apr 15, 2019 10:25 am    Post subject: Reply with quote

le copertine dei libri ci stano, e su debian che uso la stesa libreria si vedono, solo su gentoo mi da questo problema
_________________
Distribuzione: Gentoo x86_64
Desktop: GNOME 3.30.2
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21549
Location: here

PostPosted: Mon Apr 15, 2019 11:44 am    Post subject: Reply with quote

Massimog wrote:
le copertine dei libri ci stano, e su debian che uso la stesa libreria si vedono, solo su gentoo mi da questo problema

Allora non lo so da me si vedono
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Massimog
Apprentice
Apprentice


Joined: 04 Nov 2011
Posts: 152
Location: Osimo(AN)

PostPosted: Sat Apr 20, 2019 1:41 am    Post subject: Reply with quote

se a qualcuno servisse in futuro, ho risolto il mio problema con le copertine ricompilando dev-qt/qtgui con la use flag jpeg
_________________
Distribuzione: Gentoo x86_64
Desktop: GNOME 3.30.2
Back to top
View user's profile Send private message
ilnanny
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jul 2017
Posts: 98
Location: Italy/Taranto

PostPosted: Sat Apr 20, 2019 2:03 pm    Post subject: Reply with quote

Massimog wrote:
se a qualcuno servisse in futuro, ho risolto il mio problema con le copertine ricompilando dev-qt/qtgui con la use flag jpeg

si è vero ,successo anche a me ,ma non avevo pi seguito la discussione per un problema con le notifiche tramite email ,che ho appena risolto. Grazie comunque per la segnalazione .
_________________
== Lila-HD-icon-theme ==
https://github.com/ilnanny/Lila-HD-icon-theme
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum