Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] [#666418] libreoffice compilation fails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on ARM
View previous topic :: View next topic  
Author Message
Khumarahn
Apprentice
Apprentice


Joined: 17 Apr 2009
Posts: 162

PostPosted: Fri Sep 21, 2018 9:45 am    Post subject: [SOLVED] [#666418] libreoffice compilation fails Reply with quote

I have a strange error trying to compile libreoffice-6.1.1.2 in an aarch64 qemu chroot.

Code:
checking font mapping for 'Calibri'...  * ACCESS DENIED:  mkostemp:     /usr/share/fonts/Speedo/.uuid.TMP-XXXXXX
 * ACCESS DENIED:  unlink:       /usr/share/fonts/Speedo/.uuid
 * ACCESS DENIED:  mkostemp:     /usr/share/fonts/cyrillic/.uuid.TMP-XXXXXX
 * ACCESS DENIED:  unlink:       /usr/share/fonts/cyrillic/.uuid
 * ACCESS DENIED:  mkostemp:     /usr/share/fonts/util/.uuid.TMP-XXXXXX
 * ACCESS DENIED:  unlink:       /usr/share/fonts/util/.uuid
 * ACCESS DENIED:  mkostemp:     /usr/share/fonts/encodings/large/.uuid.TMP-XXXXXX
 * ACCESS DENIED:  unlink:       /usr/share/fonts/encodings/large/.uuid
configure: WARNING: unknown (LiberationSans-Regular.ttf)
checking font mapping for 'DejaVuSans'...  * ACCESS DENIED:  mkostemp:     /usr/share/fonts/Speedo/.uuid.TMP-XXXXXX
 * ACCESS DENIED:  unlink:       /usr/share/fonts/Speedo/.uuid
 * ACCESS DENIED:  mkostemp:     /usr/share/fonts/cyrillic/.uuid.TMP-XXXXXX
 * ACCESS DENIED:  unlink:       /usr/share/fonts/cyrillic/.uuid
 * ACCESS DENIED:  mkostemp:     /usr/share/fonts/util/.uuid.TMP-XXXXXX
 * ACCESS DENIED:  unlink:       /usr/share/fonts/util/.uuid
 * ACCESS DENIED:  mkostemp:     /usr/share/fonts/encodings/large/.uuid.TMP-XXXXXX
 * ACCESS DENIED:  unlink:       /usr/share/fonts/encodings/large/.uuid
ok


It looks like the script tries to leave the sanbox and create temp files in /usr/share/fonts. Does anyone reproduce this?

Complete build log: https://pastebin.com/3PxueZ1r


Last edited by Khumarahn on Fri Sep 21, 2018 10:34 am; edited 1 time in total
Back to top
View user's profile Send private message
baaann
Guru
Guru


Joined: 23 Jan 2006
Posts: 539
Location: uk

PostPosted: Fri Sep 21, 2018 10:06 am    Post subject: Reply with quote

May not be related on ARM, but you probably need to update media-libs/fontconfig as per this bug

https://bugs.gentoo.org/666418
Back to top
View user's profile Send private message
Khumarahn
Apprentice
Apprentice


Joined: 17 Apr 2009
Posts: 162

PostPosted: Fri Sep 21, 2018 10:34 am    Post subject: Reply with quote

oh, thanks!! That does it. There is a lot of bugs about it on the bugzilla...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on ARM All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum