Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dev-python/matplotlib-2.2.2-r1 failed to compile on rpi3 64
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on ARM
View previous topic :: View next topic  
Author Message
orion777
Apprentice
Apprentice


Joined: 15 Mar 2017
Posts: 163
Location: Riga, Latvia

PostPosted: Tue Jul 10, 2018 3:53 am    Post subject: dev-python/matplotlib-2.2.2-r1 failed to compile on rpi3 64 Reply with quote

Raspberry PI 3B with 64 bit gentoo from the sakakis' image https://forums.gentoo.org/viewtopic-t-1058530-postdays-0-postorder-asc-start-0.html
pi64 ~ # emerge --info '=dev-python/matplotlib-2.2.2-r1::gentoo'
Code:
Portage 2.3.41 (python 3.5.5-final-0, default/linux/arm64/17.0/desktop, gcc-7.3.0, glibc-2.27-r5, 4.14.44-v8-4fca48b7612d-bis+ aarch64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.14.44-v8-4fca48b7612d-bis+-aarch64-with-gentoo-2.6
KiB Mem:      992080 total,    116248 free
KiB Swap:     524284 total,    503508 free
Timestamp of repository gentoo: Sat, 30 Jun 2018 00:45:01 +0000
Head commit of repository gentoo: 7cf1f7ce9a8794d22cdd6dbee29e8455c2dfb733
Head commit of repository sakaki-tools: 72f435c3ecdf90e78fb3d9ab1db35983e335f7a3

Head commit of repository rpi3: 65d93d0fc7dd7f95071d41c9dfac27d1605b7129

sh bash 4.4_p23
ld GNU ld (Gentoo 2.30 p3) 2.30.0
distcc 3.2rc1 aarch64-unknown-linux-gnu [disabled]
app-shells/bash:          4.4_p23::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.26.2::gentoo
dev-lang/python:          2.7.15::gentoo, 3.5.5-r1::gentoo
dev-util/cmake:           3.11.4::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6::gentoo
sys-apps/openrc:          0.38.1::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.16.1-r1::gentoo
sys-devel/binutils:       2.30-r3::gentoo
sys-devel/gcc:            7.3.0-r3::gentoo
sys-devel/gcc-config:     1.9.1::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r3::gentoo
sys-kernel/linux-headers: 4.17::gentoo (virtual/os-headers)
sys-libs/glibc:           2.27-r5::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://isshoni.org/gentoo-portage-pi64
    priority: -1000
    sync-rsync-verify-metamanifest: no
    sync-rsync-extra-opts:
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-jobs: 1

sakaki-tools
    location: /usr/local/portage/sakaki-tools
    sync-type: git
    sync-uri: https://github.com/sakaki-/sakaki-tools.git
    masters: gentoo
    priority: 50

rpi3
    location: /usr/local/portage/rpi3
    sync-type: git
    sync-uri: https://github.com/sakaki-/rpi3-overlay.git
    masters: gentoo
    priority: 100

ACCEPT_KEYWORDS="arm64 ~arm64"
ACCEPT_LICENSE="@FREE CC-Sampling-Plus-1.0"
CBUILD="aarch64-unknown-linux-gnu"
CFLAGS="-march=armv8-a+crc -mtune=cortex-a53 -O2 -pipe"
CHOST="aarch64-unknown-linux-gnu"
CONFIG_PROTECT="/boot/cmdline.txt /boot/config.txt /etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=armv8-a+crc -mtune=cortex-a53 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs=5 --load-average=4"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles getbinpkg merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://trumpetti.atm.tut.fi/gentoo/"
LANG="en_GB.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5 -l4"
PKGDIR="/usr/portage/packages"
PORTAGE_BINHOST="https://isshoni.org/pi64pie"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa arm64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit crypt cups cxx dbus dri dts dvdr egl emboss encode exif fam ffmpeg flac fortran gdbm gif glamor gles1 gles2 gpm gtk iconv ipv6 jpeg lcms libnotify libtirpc lock mad mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds qt3support qt4 qt5 readline seccomp spell ssl startup-notification svg tcpd thunar tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xattr xcb xml xv xvid zlib" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon plan sheets stage words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_ARM="edsp neon thumb thumb2 v4 v5 v6 v7 v8 vfp vfp-d32 vfpv3 vfpv4" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5 postgres10" PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5" QEMU_SOFTMMU_TARGETS="aarch64 arm i386 x86_64" QEMU_USER_TARGETS="aarch64" RUBY_TARGETS="ruby21 ruby23" USERLAND="GNU" VIDEO_CARDS="fbdev vc4" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

pi64 ~ # emerge -pqv '=dev-python/matplotlib-2.2.2-r1::gentoo'
Code:
Local copy of remote index is up-to-date and will be used.
[ebuild  N    ] dev-python/matplotlib-2.2.2-r1  USE="cairo qt5 wxwidgets -doc -examples -excel -gtk2 -gtk3 -latex {-test} -tk" PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6"

pi64 ~ # cat /var/tmp/portage/dev-python/matplotlib-2.2.2-r1/temp/build.log
Code:
 * Package:    dev-python/matplotlib-2.2.2-r1
 * Repository: gentoo
 * Maintainer: sci@gentoo.org python@gentoo.org
 * USE:        arm64 cairo elibc_glibc kernel_linux python_targets_python2_7 python_targets_python3_5 qt5 userland_GNU wxwidgets
 * FEATURES:   preserve-libs sandbox userpriv usersandbox
>>> Unpacking source...
>>> Unpacking matplotlib-2.2.2.tar.gz to /var/tmp/portage/dev-python/matplotlib-2.2.2-r1/work
>>> Source unpacked in /var/tmp/portage/dev-python/matplotlib-2.2.2-r1/work
>>> Preparing source in /var/tmp/portage/dev-python/matplotlib-2.2.2-r1/work/matplotlib-2.2.2 ...
 * Applying matplotlib-2.2.2-doc-make.patch ...
 [ ok ]
 * Will copy sources from /var/tmp/portage/dev-python/matplotlib-2.2.2-r1/work/matplotlib-2.2.2
 * python2_7: copying to /var/tmp/portage/dev-python/matplotlib-2.2.2-r1/work/matplotlib-2.2.2-python2_7
 * python3_5: copying to /var/tmp/portage/dev-python/matplotlib-2.2.2-r1/work/matplotlib-2.2.2-python3_5
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-python/matplotlib-2.2.2-r1/work/matplotlib-2.2.2 ...
 * python2_7: running distutils-r1_run_phase python_configure
 * python3_5: running distutils-r1_run_phase python_configure
 * python3_5: running distutils-r1_run_phase python_configure_all
>>> Source configured.
>>> Compiling source in /var/tmp/portage/dev-python/matplotlib-2.2.2-r1/work/matplotlib-2.2.2 ...
 * python2_7: running distutils-r1_run_phase python_compile
cp: './build/matplotlib.egg-info' and '/var/tmp/portage/dev-python/matplotlib-2.2.2-r1/work/matplotlib-2.2.2-python2_7/build/matplotlib.egg-info' are the same file
python2.7 setup.py build --build-lib=/var/tmp/portage/dev-python/matplotlib-2.2.2-r1/work/matplotlib-2.2.2-python2_7/build/lib
============================================================================
Edit setup.cfg to change the build options

BUILDING MATPLOTLIB
            matplotlib: yes [2.2.2]
                python: yes [2.7.15 (default, Jun 29 2018, 04:31:06)  [GCC
                        6.4.0]]
              platform: yes [linux2]

REQUIRED DEPENDENCIES AND EXTENSIONS
                 numpy: yes [version 1.13.3]
      install_requires: yes [handled by setuptools]
                libagg: yes [pkg-config information for 'libagg' could not
                        be found. Using local copy.]
              freetype: yes [version unknown]
                   png: yes [version 1.6.34]
                 qhull: yes [pkg-config information for 'libqhull' could not
                        be found. Using local copy.]

OPTIONAL SUBPACKAGES
           sample_data: yes [installing]
              toolkits: yes [installing]
                 tests: no  [skipping due to configuration]
        toolkits_tests: no  [skipping due to configuration]

OPTIONAL BACKEND EXTENSIONS
                macosx: no  [Mac OS-X only]
Fatal Error: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1010,wx containers,compatible with 2.8),
and wxPython used 3.0 (wchar_t,compiler with C++ ABI 1011,wx containers,compatible with 2.8).
/var/tmp/portage/dev-python/matplotlib-2.2.2-r1/temp/environment: line 1742:  8535 Aborted                 "${@}"
 * ERROR: dev-python/matplotlib-2.2.2-r1::gentoo failed (compile phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line  124:  Called src_compile
 *   environment, line 4220:  Called distutils-r1_src_compile
 *   environment, line 1179:  Called _distutils-r1_run_foreach_impl 'python_compile'
 *   environment, line  478:  Called python_foreach_impl 'distutils-r1_run_phase' 'python_compile'
 *   environment, line 3662:  Called multibuild_foreach_variant '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'python_compile'
 *   environment, line 2745:  Called _multibuild_run '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'python_compile'
 *   environment, line 2743:  Called _python_multibuild_wrapper 'distutils-r1_run_phase' 'python_compile'
 *   environment, line  829:  Called distutils-r1_run_phase 'python_compile'
 *   environment, line 1172:  Called python_compile
 *   environment, line 3190:  Called wrap_setup 'distutils-r1_python_compile' '--build-lib=/var/tmp/portage/dev-python/matplotlib-2.2.2-r1/work/matplotlib-2.2.2-python2_7/build/lib'
 *   environment, line 5087:  Called distutils-r1_python_compile '--build-lib=/var/tmp/portage/dev-python/matplotlib-2.2.2-r1/work/matplotlib-2.2.2-python2_7/build/lib'
 *   environment, line 1047:  Called esetup.py 'build' '--build-lib=/var/tmp/portage/dev-python/matplotlib-2.2.2-r1/work/matplotlib-2.2.2-python2_7/build/lib'
 *   environment, line 1749:  Called die
 * The specific snippet of code:
 *       "${@}" || die "${die_args[@]}";
 *
 * If you need support, post the output of `emerge --info '=dev-python/matplotlib-2.2.2-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-python/matplotlib-2.2.2-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-python/matplotlib-2.2.2-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/matplotlib-2.2.2-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-python/matplotlib-2.2.2-r1/work/matplotlib-2.2.2-python2_7'
 * S: '/var/tmp/portage/dev-python/matplotlib-2.2.2-r1/work/matplotlib-2.2.2'
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19913
Location: here

PostPosted: Tue Jul 10, 2018 6:07 am    Post subject: Reply with quote

Code:
Fatal Error: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1010,wx containers,compatible with 2.8),
and wxPython used 3.0 (wchar_t,compiler with C++ ABI 1011,wx containers,compatible with 2.8).

Try to recompile x11-libs/wxGTK
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
orion777
Apprentice
Apprentice


Joined: 15 Mar 2017
Posts: 163
Location: Riga, Latvia

PostPosted: Tue Jul 10, 2018 6:49 am    Post subject: Reply with quote

It will recompile from
Code:
pi64 ~ # eix wxgtk
[U] x11-libs/wxGTK
     Available versions:
     (2.8)  (*)2.8.12.1-r2{tbz2}
     (3.0)  (~)3.0.3 (~)3.0.4{tbz2}
     (3.0-gtk3) (*)3.0.3-r300 (~*)3.0.4-r300{tbz2}
       {+X aqua debug doc gnome gstreamer libnotify odbc opengl pch sdl tiff webkit ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  2.8.12.1-r2(2.8){tbz2}(08:38:52 10/07/18)(X opengl tiff -aqua -debug -doc -gnome -gstreamer -odbc -pch -sdl ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="-32 -64 -x32") 3.0.4(3.0){tbz2}(08:59:23 03/06/18)(X libnotify opengl tiff -aqua -debug -doc -gstreamer -sdl ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="-32 -64 -x32"

to
Code:
 pi64 ~ # emerge -av =x11-libs/wxGTK-3.0.4
[binary   R    ] x11-libs/wxGTK-3.0.4:3.0::gentoo  USE="X libnotify opengl tiff (-aqua) -debug -doc -gstreamer (-sdl)" 7,976 KiB
Total: 1 package (1 reinstall, 1 binary), Size of downloads: 7,976 KiB


Ok, lets see..

Code:
pi64 ~ # emerge -av dev-python/matplotlib
[ebuild  N     ] dev-python/matplotlib-2.2.2-r1::gentoo  USE="cairo qt5 wxwidgets -doc -examples -excel -gtk2 -gtk3 -latex {-test} -tk" PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6" 0 KiB


Same result
Code:
Fatal Error: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1010,wx containers,compatible with 2.8),
and wxPython used 3.0 (wchar_t,compiler with C++ ABI 1011,wx containers,compatible with 2.8).


Last edited by orion777 on Tue Jul 10, 2018 8:06 am; edited 3 times in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19913
Location: here

PostPosted: Tue Jul 10, 2018 7:07 am    Post subject: Reply with quote

Probably you had to recompile version installed, in your case version 3.0.4 not new slot 3.0.4-r300
Code:
# emerge -1 x11-libs/wxGTK:3.0

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
orion777
Apprentice
Apprentice


Joined: 15 Mar 2017
Posts: 163
Location: Riga, Latvia

PostPosted: Tue Jul 10, 2018 8:08 am    Post subject: Reply with quote

So, I was uninstall 3.0.3-r300 and reinstall 2.8.12.1-r and then 3.0.3. Nothing help..
The third post has been edited accordingly.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19913
Location: here

PostPosted: Tue Jul 10, 2018 8:30 am    Post subject: Reply with quote

Ok it's a bug, workaround is compile mathplotlib without wxwidgets use flag
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 41555
Location: 56N 3W

PostPosted: Tue Jul 10, 2018 11:22 am    Post subject: Reply with quote

orion777,

I have it.
Code:
arm64-build ~ # eix dev-python/matplotlib
[I] dev-python/matplotlib
     Available versions:  (~)2.2.2-r1 **9999 {cairo doc examples excel fltk gtk2 gtk3 latex qt5 test tk wxwidgets PYTHON_TARGETS="python2_7 python3_4 python3_5 python3_6"}
     Installed versions:  2.2.2-r1(16:02:30 06/19/18)(cairo doc latex qt5 wxwidgets -examples -excel -gtk2 -gtk3 -test -tk PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6")


Its in my binhost.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 10145
Location: Somewhere over Atlanta, Georgia

PostPosted: Tue Jul 10, 2018 3:04 pm    Post subject: Reply with quote

Moved from Portage & Programming to Gentoo on ARM.

- John
_________________
I can confirm that I have received between 0 and 499 National Security Letters.
Back to top
View user's profile Send private message
orion777
Apprentice
Apprentice


Joined: 15 Mar 2017
Posts: 163
Location: Riga, Latvia

PostPosted: Wed Jul 11, 2018 6:19 am    Post subject: Reply with quote

So, if Neddy is able to install, but I'm not, so where is the difference?
Code:
 dev-python/wxpython
     Available versions:
     (2.8)  *2.8.12.1-r2
     (3.0)  (~)3.0.2.0{tbz2}
       {cairo doc examples libnotify opengl PYTHON_TARGETS="python2_7"}
     Installed versions:  3.0.2.0(3.0){tbz2}(23:18:23 09/07/18)(cairo libnotify opengl -examples PYTHON_TARGETS="python2_7")

 x11-libs/wxGTK
     Available versions:
     (2.8)  (*)2.8.12.1-r2{tbz2}
     (3.0)  (~)3.0.3 (~)3.0.4{tbz2}
     (3.0-gtk3) (*)3.0.3-r300 (~*)3.0.4-r300{tbz2}
       {+X aqua debug doc gnome gstreamer libnotify odbc opengl pch sdl tiff webkit ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  3.0.4(3.0){tbz2}(08:59:23 03/06/18)(X libnotify opengl tiff -aqua -debug -doc -gstreamer -sdl ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="-32 -64 -x32")

 emerge -av dev-python/matplotlib
[ebuild  N     ] dev-python/matplotlib-2.2.2-r1::gentoo  USE="cairo qt5 wxwidgets -doc -examples -excel -gtk2 -gtk3 -latex {-test} -tk" PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6" 0 KiB
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19913
Location: here

PostPosted: Wed Jul 11, 2018 7:00 am    Post subject: Reply with quote

I have same error in an amd64 system
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
orion777
Apprentice
Apprentice


Joined: 15 Mar 2017
Posts: 163
Location: Riga, Latvia

PostPosted: Thu Jul 12, 2018 8:50 pm    Post subject: Reply with quote

Finally, mathplotlib has been installed. To do this wxGTK ver. 3.0.3 should be used instead of 3.0.4. Should I mask 3.0.4? Do we have to report this bug?
Code:
 eix wxgtk
[U] x11-libs/wxGTK
     Available versions:
     (2.8)  (*)2.8.12.1-r2{tbz2}
     (3.0)  (~)3.0.3{tbz2} (~)3.0.4{tbz2}
     (3.0-gtk3) (*)3.0.3-r300 (~*)3.0.4-r300{tbz2}
       {+X aqua debug doc gnome gstreamer libnotify odbc opengl pch sdl tiff webkit ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  3.0.3(3.0){tbz2}(20:26:31 15/01/18)(X libnotify opengl tiff -aqua -debug -doc -gstreamer -sdl ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="-32 -64 -x32")
     Homepage:            https://wxwidgets.org/
     Description:         GTK+ version of wxWidgets, a cross-platform C++ GUI toolkit

pi64 ~ # emerge -av dev-python/matplotlib

Local copy of remote index is up-to-date and will be used.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-python/matplotlib-2.2.2-r1::gentoo  USE="cairo qt5 wxwidgets -doc -examples -excel -gtk2 -gtk3 -latex {-test} -tk" PYTHON_TARGETS="python2_7 python3_5 -python3_4 -python3_6" 0 KiB

Total: 1 package (1 new), Size of downloads: 0 KiB

Would you like to merge these packages? [Yes/No]
>>> Verifying ebuild manifests
>>> Emerging (1 of 1) dev-python/matplotlib-2.2.2-r1::gentoo
>>> Installing (1 of 1) dev-python/matplotlib-2.2.2-r1::gentoo
>>> Recording dev-python/matplotlib in "world" favorites file...
>>> Jobs: 1 of 1 complete                           Load avg: 1.86, 1.54, 1.10
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.
pi64 ~ #
Back to top
View user's profile Send private message
Dominique_71
Veteran
Veteran


Joined: 17 Aug 2005
Posts: 1613
Location: Switzerland (Romandie)

PostPosted: Fri Aug 24, 2018 9:13 am    Post subject: Reply with quote

fedeliallalinea wrote:
Code:
Fatal Error: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1010,wx containers,compatible with 2.8),
and wxPython used 3.0 (wchar_t,compiler with C++ ABI 1011,wx containers,compatible with 2.8).

Try to recompile x11-libs/wxGTK

I get the same issue with a world update. wxGTK was already merged at its last version during that update. I rebuild wxpython and now matplotlib compile fine.

Another solution, maybe when this error occur with python3.x, as suggested here, is to eselect wxwidgets to gtk3-unicode-3.0-gtk3.
_________________
[[[ To any NSA and FBI agents reading that text: please consider ]]]
[[[ whether defending the US Constitution against all enemies, ]]]
[[[ foreign or domestic, requires you to follow Snowden's example. ]]]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on ARM All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum