Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Networking device not detected outside of live cd
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
oatmealbrian
n00b
n00b


Joined: 09 May 2018
Posts: 2

PostPosted: Wed May 09, 2018 4:06 am    Post subject: Networking device not detected outside of live cd Reply with quote

I was able to establish a wireless connection using my network card (listed as wlp2s0 in ifconfig) in the live cd environment and while chrooted into my new install. However, when I reboot the system, ifconfig doesn't display wlp2s0 and displays a device called sito@none in its place. I get the following errors whenever booting my system:
Code:
     ERROR: interface wlp2s0 does not exist
     Ensure that you have loaded the correct kernel module for your hardware
ERROR: net.wlp2s0 failed to start
ERROR: cannot start netmount as net.wlp2s0 would not start

Using "lspci -k" reveals that the needed wireless network driver would be "ath10k_pci", which I enabled inside the kernel. The full output regarding the wireless network adapter card is:
Code:
2:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)
     Subsystem: Bigfoot Networks, Inc. QCA6174 802.11ac Wireless Network Adapter
     Kernel driver in use: ath10k_pci


I emerged linux-firmware after installing the kernel, emerged iw and wpa_supplicant, and created a link between lo and wlp2s0 after compiling the kernel.

Please let me know if there's any other information that should be provided.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 19635
Location: here

PostPosted: Wed May 09, 2018 6:13 am    Post subject: Reply with quote

You have already read the related wiki page
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
oatmealbrian
n00b
n00b


Joined: 09 May 2018
Posts: 2

PostPosted: Wed May 09, 2018 6:52 am    Post subject: Reply with quote

fedeliallalinea wrote:
You have already read the related wiki page


I can't believe i missed that. I followed it and it works. Thanks!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum