Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Chromium freezes my system and then have to do hard shutdown
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
hariskar
n00b
n00b


Joined: 29 Jan 2017
Posts: 64
Location: Greece/Kavala

PostPosted: Sun Apr 15, 2018 2:45 pm    Post subject: Chromium freezes my system and then have to do hard shutdown Reply with quote

When I use Chromium my system very often freezes, except the mouse cursor which moves but when I click, nothing happens. The only way to get out of this situation is press the on/off button of my PC to shutdown. Any idea why this happens?

Code:

hk@gentoo ~ $ sudo emerge --info
Portage 2.3.28 (python 3.5.5-final-0, default/linux/amd64/17.0/desktop, gcc-7.3.0, glibc-2.26-r6, 4.16.0-gentoo x86_64)
=================================================================
System uname: Linux-4.16.0-gentoo-x86_64-Intel-R-_Core-TM-_i3-4330_CPU_@_3.50GHz-with-gentoo-2.4.1
KiB Mem:     8092000 total,   7863216 free
KiB Swap:    5857276 total,   5857276 free
Timestamp of repository gentoo: Thu, 12 Apr 2018 13:00:01 +0000
Head commit of repository gentoo: 9d4bc57aab6fd50f629922b3e5bd0ea39082d745
sh bash 4.4_p19
ld GNU ld (Gentoo 2.30 p1) 2.30.0
app-shells/bash:          4.4_p19::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.26.1-r2::gentoo
dev-lang/python:          2.7.14-r1::gentoo, 3.5.5::gentoo
dev-util/cmake:           3.11.0::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.4.1-r2::gentoo
sys-apps/openrc:          0.35.5::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.16.1-r1::gentoo
sys-devel/binutils:       2.30-r1::gentoo
sys-devel/gcc:            7.3.0-r1::gentoo
sys-devel/gcc-config:     1.9.1::gentoo
sys-devel/libtool:        2.4.6-r5::gentoo
sys-devel/make:           4.2.1-r3::gentoo
sys-kernel/linux-headers: 4.16::gentoo (virtual/os-headers)
sys-libs/glibc:           2.26-r6::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-metamanifest: yes
    sync-rsync-extra-opts:
    sync-rsync-verify-max-age: 24

localrepo
    location: /usr/local/portage
    masters: gentoo

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=haswell -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qu
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/f
CXXFLAGS="-march=haswell -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-
fperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpr
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.ntua.gr/pub/linux/gentoo/ ftp://ftp.ntua.gr/pub/linux/
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-t
iles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 berkdb branding bzip2 cairo cdda cdr cli conso
k iconv jpeg lcms ldap libnotify mad mng modules mp3 mp4 mpeg multilib ncurses nl
-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidg
7x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0
core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_db
autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires e
on rewrite setenvif speling status unique_id userdir usertrack vhost_alias" COLLE
mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" INPUT_DEVICES=
01 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minim
PYTHON_SINGLE_TARGET="python3_5" PYTHON_TARGETS="python2_7 python3_5" RUBY_TARGET
2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawn
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, ENV_UNSET, INSTALL_MASK,
 PORTAGE_RSYNC_EXTRA_OPTS



Code:
~ $ sudo emerge -av chromium

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] www-client/chromium-66.0.3359.66::gentoo  USE="cups (pic) proprietary-codecs suid system-ffmpeg system-icu -component-build -custom-cflags -gnome-keyring -hangouts -jumbo-build -kerberos (-neon) -pulseaudio (-selinux) (-system-libvpx) (-tcmalloc) -widevine" L10N="am ar bg bn ca cs da de el en-GB es es-419 et fa fi fil fr gu he hi hr hu id it ja
kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr sv sw ta te th tr uk vi zh-CN zh-TW" 0 KiB


Last edited by hariskar on Sun Apr 15, 2018 2:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 18299
Location: here

PostPosted: Sun Apr 15, 2018 2:49 pm    Post subject: Reply with quote

You have enbled 'Use hardware acceleration when available' option?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
hariskar
n00b
n00b


Joined: 29 Jan 2017
Posts: 64
Location: Greece/Kavala

PostPosted: Sun Apr 15, 2018 2:52 pm    Post subject: Reply with quote

Yes it is enabled. Should I disable it?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 18299
Location: here

PostPosted: Sun Apr 15, 2018 2:54 pm    Post subject: Reply with quote

Code:
Canvas: Hardware accelerated
CheckerImaging: Disabled
Flash: Hardware accelerated
Flash Stage3D: Hardware accelerated
Flash Stage3D Baseline profile: Hardware accelerated
Compositing: Hardware accelerated
Multiple Raster Threads: Enabled
Native GpuMemoryBuffers: Software only. Hardware acceleration disabled
Rasterization: Software only. Hardware acceleration disabled
Surface Synchronization: Enabled
Video Decode: Unavailable
WebGL: Hardware accelerated
WebGL2: Hardware accelerated

It seems the case. Try to disable this option
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
hariskar
n00b
n00b


Joined: 29 Jan 2017
Posts: 64
Location: Greece/Kavala

PostPosted: Sun Apr 15, 2018 2:55 pm    Post subject: Reply with quote

OK, thanks for instant reply!
Back to top
View user's profile Send private message
hariskar
n00b
n00b


Joined: 29 Jan 2017
Posts: 64
Location: Greece/Kavala

PostPosted: Mon Apr 16, 2018 12:27 pm    Post subject: Reply with quote

Could it be because of the nouveau drivers? In the same dual boot pc in Chrome in windows and 'Use hardware acceleration when available' enabled, there is no problem.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 18299
Location: here

PostPosted: Mon Apr 16, 2018 1:43 pm    Post subject: Reply with quote

The problem is 'Use hardware acceleration when available' on linux isn't full supported
https://forums.gentoo.org/viewtopic-t-1079416.html
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum