Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
TypeError: argument (impossible<bad format char>) and more
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on ARM
View previous topic :: View next topic  
Author Message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 46368
Location: 56N 3W

PostPosted: Mon Dec 11, 2017 2:29 pm    Post subject: TypeError: argument (impossible<bad format char>) and Reply with quote

Team,

Since switching my 64 bit Pi 3 to the default/linux/arm64/17.0/desktop profile, I can no longer produce binary packages.
It all ends in tears with
Code:
Pi3_64 portage # quickpkg dev-libs/icu
 * Building package for dev-libs/icu-58.2-r1 ...Traceback (most recent call last):
  File "/usr/lib/python-exec/python2.7/quickpkg", line 382, in <module>
    retval = quickpkg_main(options, args, eout)
  File "/usr/lib/python-exec/python2.7/quickpkg", line 307, in quickpkg_main
    quickpkg_atom(options, infos, atom, eout)
  File "/usr/lib/python-exec/python2.7/quickpkg", line 137, in quickpkg_atom
    xpdata = xpak.xpak(dblnk.dbdir)
  File "/usr/lib64/python2.7/site-packages/portage/xpak.py", line 107, in xpak
    xpak_segment = xpak_mem(mydata)
  File "/usr/lib64/python2.7/site-packages/portage/xpak.py", line 135, in xpak_mem
    indexglob = indexglob + encodeint(len(x)) + x + encodeint(datapos) + encodeint(mydatasize)
  File "/usr/lib64/python2.7/site-packages/portage/xpak.py", line 67, in encodeint
    a.append((myint >> 24) & 0xff)
TypeError: argument (impossible<bad format char>)
Pi3_64 portage #

That's a demo produced with quickpkg. FEATURES=buildpkg produces the same results.
amd64 and x86 are OK, hence the post here.

I've rebuilt all the installed pyton versions and updated portage to no effect so far.

There is more, that may or may not be connected. Heres an example
dev-python:cffi-1.11.2:20171211-001925.log:
running build_ext
sandbox:stop  caught signal 2 in pid 28172
sandbox:stop  Send signal 4 more times to force SIGKILL
sandbox:stop  Send signal 3 more times to force SIGKILL
sandbox:stop  Send signal 2 more times to force SIGKILL
sandbox:stop  Send signal 1 more time to force SIGKILL
Sandboxed process killed by signal: Killed


Anything that calls build_ext hangs forever. Killing the emerge' as above, leaves the process running in the background using 100% of one core.

Thoughts and pointers will be useful.


-- edit --

It might be two separate issues I missed the

Code:
/usr/bin/python2.7 setup.py build
/usr/lib/gcc/aarch64-unknown-linux-gnu/7.2.0/../../../../lib64/Scrt1.o: In function `_start':
(.text+0x18): undefined reference to `main'
(.text+0x1c): undefined reference to `main'
error before the hang.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on ARM All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum