Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dubiose eix-test-obsolete Ausgabe
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Erdie
Veteran
Veteran


Joined: 20 May 2004
Posts: 1891
Location: Heidelberg - Germany

PostPosted: Sat Aug 12, 2017 5:57 pm    Post subject: dubiose eix-test-obsolete Ausgabe Reply with quote

eix-test-obsolete liefert mit u. a. folgende Ausgabe:
Code:

Folgende installierte Pakete befinden sich nicht in der Datenbank:
dev-java/-MERGING-tomcat-servlet-api


ein Paket mit dem Namen gibt es nicht. Was soll mir die Meldung sagen?
_________________
Desktop AMD FX-4300 12GB RAM, Asus GF GTX 650. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000.
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi 1 + 2 + Zero W
Back to top
View user's profile Send private message
yuhu
Tux's lil' helper
Tux's lil' helper


Joined: 17 Oct 2006
Posts: 86

PostPosted: Sat Aug 12, 2017 6:23 pm    Post subject: Reply with quote

Hi,

ich bekomme schon seit geraumer Zeit eine ähnliche Ausgabe.

Quote:
Folgende installierte Pakete befinden sich nicht in der Datenbank:
dev-java/-MERGING-ant-jmf


Ein Paket gibt es ebenfalls nicht. :?:
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4325

PostPosted: Sat Aug 12, 2017 6:43 pm    Post subject: Reply with quote

der Teil "-MERGIN" sieht so aus als ob das ein überbleibsel einer nicht vollständig durchgeführten installation eines paketes ist.
Im falle von Erdie scheint eine version des pakets dev-jave/tomcat-servlet-api nicht komplett installiert worden.

Kann es sein, dass z.b. "-MERGING-tomcat-servlet-api" irgendwo auf der festplatte als datei/Verzeichnis vorhanden ist? (eventuell im portage build temp verzeichnis)
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3213
Location: Germany

PostPosted: Sat Aug 12, 2017 6:53 pm    Post subject: Reply with quote

Ja, das hat eix gut erkannt :)

Es gibt
dev-java/tomcat-servlet-api
und auch
dev-java/ant-jmf

Ja, dieser -MERGING- Zusatz vor dem Paketnamen scheint ein fehlerhafter Eintrag in der Datenbank zu sein.
Schaut mal unter /var/db/pkg/dev-java/
ob dort dieser Eintrag wirklich so vorhanden ist.
Back to top
View user's profile Send private message
Erdie
Veteran
Veteran


Joined: 20 May 2004
Posts: 1891
Location: Heidelberg - Germany

PostPosted: Sat Aug 12, 2017 7:33 pm    Post subject: Reply with quote

Ja, es gibt eine Verzeichnis unter dem angegebenen Pfad mit genau dem Namen!
_________________
Desktop AMD FX-4300 12GB RAM, Asus GF GTX 650. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000.
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi 1 + 2 + Zero W
Back to top
View user's profile Send private message
yuhu
Tux's lil' helper
Tux's lil' helper


Joined: 17 Oct 2006
Posts: 86

PostPosted: Sat Aug 12, 2017 7:47 pm    Post subject: Reply with quote

In der Tat, Danke :D
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3213
Location: Germany

PostPosted: Sat Aug 12, 2017 9:32 pm    Post subject: Reply with quote

Huh ja, ist nicht schön, und sollte normal nicht vorkommen :-/
Soweit ich gehört hab kann es zb dazu kommen wenn im ungünstigen Fall - zb während der Install-Phase - es zu einem Stromausfall kommt, zb Akku alle oder ähnliches.

Vorschlag:
Normal sollte man an der Datenbank eigentlich überhaupt nicht manuell herum editieren.
Aber, in diesem Fall würde ich vorschlagen den Eintrag, den Paketnamen zu korrigieren.
Überprüft dann aber bitte ob es nach der Korrektur den Eintrag nicht doppelt gibt. Falls es ihn doppelt gibt, dann müsste man sich beide anschauen und entscheiden welchen man entfernt.
Und dann, nach der Korrektur, ist es wohl am besten das Paket neu zu mergen (sofern es installiert ist), so das der Eintrag noch mal neu geschrieben wird.
Damit sollte das ganze dann hoffentlich soweit wieder in ordnung sein.
Back to top
View user's profile Send private message
Erdie
Veteran
Veteran


Joined: 20 May 2004
Posts: 1891
Location: Heidelberg - Germany

PostPosted: Sun Aug 13, 2017 9:11 am    Post subject: Reply with quote

Das ebuild mit dem Namen "tomcat-servlet-api" ist bei mir nicht installiert. Kann ich deshalb davon ausgehen, dass ich diesen Eintrag gefahrlos löschen kann?
_________________
Desktop AMD FX-4300 12GB RAM, Asus GF GTX 650. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000.
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi 1 + 2 + Zero W
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3213
Location: Germany

PostPosted: Sun Aug 13, 2017 10:49 am    Post subject: Reply with quote

Hm, mit löschen in der Datenbank wäre ich vorsichtig :-/
Wie gesagt, normal sollte man eigentlich niemals in der Datenbank manuell selbst was ändern müssen.
Beachte, all diese Informationen aus der Datenbank nutzt portage um Abhängigkeiten zu berechnen. Ich bin mir ehrlich gesagt nicht sicher ob es eventuell mal zu unerwünschten Nebenwirkungen kommen könnte, wenn plötzlich Teileinträge der Datenbank (da sind zb auch fortlaufend nummerierte Counter mit bei) nicht mehr vorhanden sind (oder eventuell nicht mehr zusammen passen).
Im Zweifel würde ich eher nur den defekten Paketnamen korrigieren, und dann gut sein lassen.
Back to top
View user's profile Send private message
Erdie
Veteran
Veteran


Joined: 20 May 2004
Posts: 1891
Location: Heidelberg - Germany

PostPosted: Wed Aug 16, 2017 8:38 am    Post subject: Reply with quote

nach Umbenennung des Verzeichnisses, kommt folgendes. So ganz sauber erscheint mir das nicht.


Code:

Folgende installierte Pakete sind nicht in der Datenbank:
[U] dev-java/tomcat-servlet-api (8.0.39(3.1)@12.03.2017 -> 3(2.2) 4.1.36(2.3) 5.5.27-r1(2.4) 6.0.44-r1(2.5) 7.0.77(3.0) 8.0.43(3.1)): Tomcat's Servlet API 4.0/JSP API 2.4?/EL API 3.1? implementation


Wieso nimmt eix jetzt an, das Pakte wäre installiert?

BTW: Ich hatte zuvor tomcat-servlet-api mit oneshot installiert und anschließend mit depclean wieder entfernt. Das hatte ncihts geändert. Aber es traten file collisions auf. In der Datenbank erscheit das ebuild dann mit einer höheren Version.
_________________
Desktop AMD FX-4300 12GB RAM, Asus GF GTX 650. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000.
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi 1 + 2 + Zero W
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3213
Location: Germany

PostPosted: Wed Aug 16, 2017 9:58 am    Post subject: Re: dubiose eix-test-obsolete Ausgabe Reply with quote

Naja, du solltest schon versuchen exakt die Version von dem vormals defekten Eintrag zu deinstallieren. (Beachte, das Paket gibt es sloted, es können also auch mehrere Versionen gleichzeitig installiert sein).
Erdie wrote:
eix-test-obsolete liefert mit u. a. folgende Ausgabe:
Code:

Folgende installierte Pakete befinden sich nicht in der Datenbank:
dev-java/-MERGING-tomcat-servlet-api
[...]

Hier ist leider nicht ersichtlich um welche Version es geht. Schau doch mal in das Verzeichnis, dort sollte normal auch ein ebuild mit Versionsnummer liegen. Auch wenn es die Version aktuell im Tree eventuell schon nicht mehr gibt - versuche mal exakt die genaue Version zu deinstallieren.
Back to top
View user's profile Send private message
Erdie
Veteran
Veteran


Joined: 20 May 2004
Posts: 1891
Location: Heidelberg - Germany

PostPosted: Wed Aug 16, 2017 12:30 pm    Post subject: Reply with quote

hat funktoiniert, danke!
_________________
Desktop AMD FX-4300 12GB RAM, Asus GF GTX 650. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000.
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi 1 + 2 + Zero W
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum