Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Logitech Quickcam Communicate STX video works but no mic
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Astronome
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 148

PostPosted: Tue Jul 25, 2017 5:35 pm    Post subject: Logitech Quickcam Communicate STX video works but no mic Reply with quote

I enabled this driver in the kernel. I'm able to use the webcam in Firefox for video, but the mic apparently doesn't work. I enabled the snd-usb-audio driver as an attempt to enable the mic. I can confirm that it's loaded from the output of lsmod:

Code:

Module                  Size  Used by
ipt_REJECT              1585  2
nf_reject_ipv4          2483  1 ipt_REJECT
xt_owner                1579  4
iptable_filter          1592  1
ip_tables              13579  1 iptable_filter
carl9170               74399  0
ath                    18514  1 carl9170
snd_usb_audio         129281  2
snd_hwdep               5994  1 snd_usb_audio
snd_usbmidi_lib        19515  1 snd_usb_audio
snd_seq_midi            4774  0
snd_ca0106             32338  1
snd_ac97_codec        106092  1 snd_ca0106
ac97_bus                1630  1 snd_ac97_codec
snd_rawmidi            17836  3 snd_usbmidi_lib,snd_ca0106,snd_seq_midi
zd1211rw               49530  0
gspca_zc3xx            41832  0
gspca_main             23412  1 gspca_zc3xx
edac_core              39181  0
v4l2_common             3125  1 gspca_main
videodev              129422  3 gspca_main,v4l2_common,gspca_zc3xx
i2c_piix4               8601  0
radeon               1410936  3
ttm                    67844  1 radeon
atl1e                  28266  0


But I don't see any audio devices in lsusb:

Code:

Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 002: ID 17ef:600e Lenovo
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 003: ID 0461:4e04 Primax Electronics, Ltd
Bus 003 Device 002: ID 046d:08ad Logitech, Inc. QuickCam Communicate STX
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 006: ID 1668:1200 Actiontec Electronics, Inc. [hex] 802AIN Wireless N Network Adapter [Atheros AR9170+AR9101]
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


I have both a controlC0 and controlC1 in /dev/snd. In amixer, I can switch between my primary sound card and "USB Device 0x46d:0x8ad", which wasn't there before I enabled the snd-usb-audio module. There's only one control available, and I can only set it to on or off. There's no volume slider. Here's the output of arecord -l:

Code:

**** List of CAPTURE Hardware Devices ****
card 0: CA0106 [CA0106], device 0: ca0106 [CA0106]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: CA0106 [CA0106], device 1: ca0106 [CA0106]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: CA0106 [CA0106], device 2: ca0106 [CA0106]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: CA0106 [CA0106], device 3: ca0106 [CA0106]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: U0x46d0x8ad [USB Device 0x46d:0x8ad], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


I'm testing this in Blue Jeans because that's what my company uses. If there's an easier way to test, maybe by cutting out the web browser, that'd be cool.
Back to top
View user's profile Send private message
Astronome
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 148

PostPosted: Tue Jul 25, 2017 11:03 pm    Post subject: Reply with quote

I found the volume slider in alsamixer for the webcam by pressing F4. I turned that all the way up and tried recording with arecord, but on playback there is no sound other than static.

I also found another mic that plugs into one of the ports on my sound card, but it doesn't seem to be working either. There are several more controls with sliders for this device in alsamixer labeled "Line in", "Mic", "Phone" and "Aux". I have each of these turned all the way up. Finally, there are controls without sliders that can be set to one of the following options:

Analog Source
- Phone
- Mic
- Line in
- Aux

Digital Source
- IEC958 out
- i2s mixer out
- IEC958 in
- i2s in
- AC97 in
- SRC out

Shared Mic/Line
- Line in
- Mic in

I've been experimenting with these but I'm not sure what I'm doing. I discovered that if I change the "Shared Mic/Line" to "Mic in", I the speakers act as an amplifier for the mic, so apparently the mic works.


Last edited by Astronome on Tue Jul 25, 2017 11:44 pm; edited 2 times in total
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1363

PostPosted: Tue Jul 25, 2017 11:09 pm    Post subject: Reply with quote

ok, quick question, but did you make sure it is NOT muted in alsamixer? Sound devices tend to be muted by default, so you need to remember to unmute them.
Back to top
View user's profile Send private message
Astronome
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2016
Posts: 148

PostPosted: Tue Jul 25, 2017 11:09 pm    Post subject: Reply with quote

ct85711 wrote:
ok, quick question, but did you make sure it is NOT muted in alsamixer? Sound devices tend to be muted by default, so you need to remember to unmute them.


Yes, all volume sliders are turned all the way up.

One other thing. When using arecord I get an error that I don't understand:

Code:

$ arecord -d 10 test.wav
Recording WAVE 'test.wav' : Unsigned 8 bit, Rate 8000 Hz, Mono
overrun!!! (at least 0.065 ms long)


Not sure if relevant.

[img]http://imgur.com/MXP1xat.png[/img]

[img]http://imgur.com/5qYs0Fh.png[/img]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum