Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ibook G4 issues
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
hilti_hit
n00b
n00b


Joined: 15 Oct 2011
Posts: 5

PostPosted: Sun Jul 05, 2015 12:55 pm    Post subject: ibook G4 issues Reply with quote

processor : 0
cpu : 7447A, altivec supported
clock : 533.333000MHz
revision : 1.1 (pvr 8003 0101)
bogomips : 36.86
timebase : 18432000
platform : PowerMac
model : PowerBook6,5
machine : PowerBook6,5
motherboard : PowerBook6,5 MacRISC3 Power Macintosh
detected as : 287 (iBook G4)
pmac flags : 0000001a
L2 cache : 512K unified
pmac-generation : NewWorld
Memory : 768 MB

Hi, i still have some unsolved Problems with my iBook G4, which i'm trying to set up:

1.; no idea how to get ALSA working, tried a lot with and without snd-aoa-* and snd-powermac, even patching the kernel, like here:
https://lists.debian.org/debian-powerpc/2013/09/msg00031.html

2.; still no suspend to ram, hibernate is working (problems with NetworkManager at restart)

3.;ALL browsers with net-libs/webkit-gtk have segfault issues. Only "surf -s" is starting, so i think it is a bug related to javascript. I think debian had the same problem and they patched webkit for ppc.
Qtwebkit works.

4.; cdrom is working, but i need to mount it manually.

I hope, someone can help me, and sorry for the bad english.
Back to top
View user's profile Send private message
Keruskerfuerst
Advocate
Advocate


Joined: 01 Feb 2006
Posts: 2268
Location: near Augsburg, Germany

PostPosted: Sun Jul 12, 2015 4:27 pm    Post subject: Reply with quote

Mount problem: start automounter or use udev.
Back to top
View user's profile Send private message
rican-linux
n00b
n00b


Joined: 13 Apr 2015
Posts: 33

PostPosted: Thu Jul 23, 2015 5:39 am    Post subject: Re: ibook G4 issues Reply with quote

hilti_hit wrote:
processor : 0
cpu : 7447A, altivec supported
clock : 533.333000MHz
revision : 1.1 (pvr 8003 0101)
bogomips : 36.86
timebase : 18432000
platform : PowerMac
model : PowerBook6,5
machine : PowerBook6,5
motherboard : PowerBook6,5 MacRISC3 Power Macintosh
detected as : 287 (iBook G4)
pmac flags : 0000001a
L2 cache : 512K unified
pmac-generation : NewWorld
Memory : 768 MB

Hi, i still have some unsolved Problems with my iBook G4, which i'm trying to set up:

1.; no idea how to get ALSA working, tried a lot with and without snd-aoa-* and snd-powermac, even patching the kernel, like here:
https://lists.debian.org/debian-powerpc/2013/09/msg00031.html

2.; still no suspend to ram, hibernate is working (problems with NetworkManager at restart)

3.;ALL browsers with net-libs/webkit-gtk have segfault issues. Only "surf -s" is starting, so i think it is a bug related to javascript. I think debian had the same problem and they patched webkit for ppc.
Qtwebkit works.

4.; cdrom is working, but i need to mount it manually.

I hope, someone can help me, and sorry for the bad english.


you should be able to get sound working with snd-aoa-i2sbus, also be sure that the files /etc/mobprobe.d/blacklist.local.conf is removed. Then run alsamixer and make sure the PCM channel is set to 80. If that does not then you may need to patch the kernel. I think this issue may be resolved with the latest 4.0 kernel.

The webkit issue is javascript based. Debian has patched it but I think they are the only ones for powerpc.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum